aboutsummaryrefslogtreecommitdiff
path: root/net/curl
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2023-05-23 17:59:55 +0000
committerStan Grishin <stangri@melmac.ca>2023-05-23 22:14:13 +0000
commitb9c7aa50f42e5680bae5c26182a359d0fed5b9ce (patch)
treecc2d25e0aa45bffee0052d0dbadde267653858ce /net/curl
parent72c8977b3b4b3b8c905bd53db7557cf6bc8963db (diff)
curl: update to 8.1.0
* https://curl.se/changes.html#8_1_0 Signed-off-by: Stan Grishin <stangri@melmac.ca>
Diffstat (limited to 'net/curl')
-rw-r--r--net/curl/Makefile6
-rw-r--r--net/curl/patches/200-no_docs_tests.patch4
2 files changed, 5 insertions, 5 deletions
diff --git a/net/curl/Makefile b/net/curl/Makefile
index c79ca80d8..d167cebfc 100644
--- a/net/curl/Makefile
+++ b/net/curl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/nls.mk
PKG_NAME:=curl
-PKG_VERSION:=8.0.1
+PKG_VERSION:=8.1.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(subst .,_,
https://dl.uxnr.de/mirror/curl/ \
https://curl.askapache.com/download/ \
https://curl.se/download/
-PKG_HASH:=0a381cd82f4d00a9a334438b8ca239afea5bfefcfa9a1025f2bf118e79e0b5f0
+PKG_HASH:=6bd80ad4f07187015911216ee7185b90d285ac5162aed1bded144f9f93232a3c
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
@@ -26,7 +26,6 @@ PKG_CPE_ID:=cpe:/a:haxx:libcurl
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
-PKG_BUILD_FLAGS:=gc-sections
PKG_CONFIG_DEPENDS:= \
CONFIG_IPV6 \
@@ -108,6 +107,7 @@ endef
TARGET_CFLAGS += $(FPIC)
TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
+TARGET_LDFLAGS += -Wl,--gc-sections
CONFIGURE_ARGS += \
--disable-debug \
diff --git a/net/curl/patches/200-no_docs_tests.patch b/net/curl/patches/200-no_docs_tests.patch
index 863c82801..d3a5cca61 100644
--- a/net/curl/patches/200-no_docs_tests.patch
+++ b/net/curl/patches/200-no_docs_tests.patch
@@ -1,6 +1,6 @@
--- a/Makefile.am
+++ b/Makefile.am
-@@ -158,7 +158,7 @@ CLEANFILES = $(VC10_LIBVCXPROJ) $(VC10_S
+@@ -159,7 +159,7 @@ CLEANFILES = $(VC10_LIBVCXPROJ) $(VC10_S
bin_SCRIPTS = curl-config
SUBDIRS = lib src
@@ -9,7 +9,7 @@
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libcurl.pc
-@@ -272,8 +272,6 @@ cygwinbin:
+@@ -273,8 +273,6 @@ cygwinbin:
# We extend the standard install with a custom hook:
install-data-hook:
(cd include && $(MAKE) install)