aboutsummaryrefslogtreecommitdiff
path: root/net/cshark/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-06-23 11:57:00 +0200
committerLuka Perkov <luka@openwrt.org>2014-06-23 11:57:00 +0200
commit63782c633da921cae59465268545af58fc9f906c (patch)
treebece67a0fe53364ab87dd8fe01491487ba242054 /net/cshark/Makefile
parente07ac05e65f157e7ec49736f2042035b3b03aa3b (diff)
cshark: add new package
Signed-off-by: Luka Perkov <luka@openwrt.org>
Diffstat (limited to 'net/cshark/Makefile')
-rw-r--r--net/cshark/Makefile75
1 files changed, 75 insertions, 0 deletions
diff --git a/net/cshark/Makefile b/net/cshark/Makefile
new file mode 100644
index 000000000..abadcfe09
--- /dev/null
+++ b/net/cshark/Makefile
@@ -0,0 +1,75 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cshark
+PKG_VERSION:=2014-06-23
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/cloudshark/cshark.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=5cb5f8888b4ec245bdf07c49f81576d1f33107ea
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/cshark
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=CloudShark capture tool
+ URL:=http://www.cloudshark.org/
+ DEPENDS:=+libjson-c +libpcap +libuci +libubox +libuclient +libustream-polarssl
+ MAINTAINER:=Luka Perkov <luka@openwrt.org>
+endef
+
+define Package/luci-app-cshark
+ SECTION:=luci
+ CATEGORY:=LuCI
+ SUBMENU:=3. Applications
+ TITLE:=Cloudshark capture tool Web UI
+ DEPENDS:=+cshark +luci
+ MAINTAINER:=Luka Perkov <luka@openwrt.org>
+endef
+
+CMAKE_OPTIONS = \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_DEBUG=OFF \
+
+define Package/cshark/conffiles
+/etc/config/cshark
+endef
+
+define Package/cshark/install
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/bin/cshark \
+ $(1)/sbin/
+
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) \
+ $(PKG_BUILD_DIR)/config/cshark \
+ $(1)/etc/config/
+
+ $(INSTALL_DIR) $(1)/etc/ssl/certs
+ $(INSTALL_CONF) \
+ $(PKG_BUILD_DIR)/config/ca-the_usertrust_network.pem \
+ $(1)/etc/ssl/certs/
+endef
+
+define Package/luci-app-cshark/install
+ $(INSTALL_DIR) $(1)/usr/lib/lua/luci
+ $(CP) -R $(PKG_BUILD_DIR)/openwrt/luci/luasrc/* $(1)/usr/lib/lua/luci/
+endef
+
+$(eval $(call BuildPackage,cshark))
+$(eval $(call BuildPackage,luci-app-cshark))