aboutsummaryrefslogtreecommitdiff
path: root/net/crowdsec
diff options
context:
space:
mode:
authorKerma Gérald <gandalf@gk2.net>2021-11-22 19:10:41 +0100
committerRosen Penev <rosenp@gmail.com>2021-11-22 16:42:43 -0800
commit2861370567bde7d426a5dda2b41cda321d050f5f (patch)
tree4078a36d7e60257cfa8b2d680079cb1ec37c630d /net/crowdsec
parent95a65fb76e9a01889af4ca93b4f3d730c33ef376 (diff)
crowdsec: update to 1.2.1
crowdsec-firewall-boucer: update to 0.0.16 Signed-off-by: Kerma Gérald <gandalf@gk2.net>
Diffstat (limited to 'net/crowdsec')
2 files changed, 3 insertions, 32 deletions
diff --git a/net/crowdsec/Makefile b/net/crowdsec/Makefile
index de22d2d4c..bd3b89e71 100644
--- a/net/crowdsec/Makefile
+++ b/net/crowdsec/Makefile
@@ -6,14 +6,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=crowdsec
-PKG_VERSION:=1.2.0
+PKG_VERSION:=1.2.1
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/crowdsecurity/crowdsec
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_SOURCE_DATE:=20210914
-PKG_MIRROR_HASH:=911af2c49c28596256c31ebb26b48c5ba9e6a0abdd46830e75e2cf4c0eff4256
+PKG_SOURCE_DATE:=20211117
+PKG_MIRROR_HASH:=dfe50e5fb4d32fb6c21275b3f13a837ad64a9054e78076b44325376dc003fc64
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
diff --git a/net/crowdsec/patches/010-fix-32bits-compile.patch b/net/crowdsec/patches/010-fix-32bits-compile.patch
deleted file mode 100644
index 58426826c..000000000
--- a/net/crowdsec/patches/010-fix-32bits-compile.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Author: Kerma Gérald <gandalf@gk2.net>
-Date: Mon Sep 20 10:34:20 2021 +0200
-
- Use math.MaxInt32 instead of math.MaxUint32
-
- To fix 32 bits compilation in v1.2.0
- https://github.com/crowdsecurity/crowdsec/issues/979
-
- Signed-off-by: Kerma Gérald <gandalf@gk2.net>
-
---- a/pkg/csplugin/broker.go
-+++ b/pkg/csplugin/broker.go
-@@ -400,14 +400,14 @@ func getProccessAtr(username string, gro
- if err != nil {
- return nil, err
- }
-- if uid < 0 && uid > math.MaxUint32 {
-+ if uid < 0 && uid > math.MaxInt32 {
- return nil, fmt.Errorf("out of bound uid")
- }
- gid, err := strconv.Atoi(g.Gid)
- if err != nil {
- return nil, err
- }
-- if gid < 0 && gid > math.MaxUint32 {
-+ if gid < 0 && gid > math.MaxInt32 {
- return nil, fmt.Errorf("out of bound gid")
- }
- return &syscall.SysProcAttr{