aboutsummaryrefslogtreecommitdiff
path: root/net/crowdsec-firewall-bouncer
diff options
context:
space:
mode:
authorS. Brusch <ne20002@gmx.ch>2023-10-21 19:22:13 +0200
committerTianling Shen <cnsztl@gmail.com>2023-11-02 00:42:00 +0800
commita8df73ce7277134c5bd318b3e63cc14e2c70e9a7 (patch)
tree406baed45eb93a203028962272e47856c644253d /net/crowdsec-firewall-bouncer
parent47c8bf1a095ea023e076e32fc51132c926360207 (diff)
crowdsec-firewall-bouncer: add ujail
* added ujail for crowdsec-firewall-bouncer * set nice to reduce priority for process Signed-off-by: S. Brusch <ne20002@gmx.ch> Maintainer: Kerma GĂ©rald <gandalf@gk2.net> Run tested: mediatek/filogic, BPI-R3, Openwrt 23.05.0
Diffstat (limited to 'net/crowdsec-firewall-bouncer')
-rw-r--r--net/crowdsec-firewall-bouncer/Makefile2
-rwxr-xr-xnet/crowdsec-firewall-bouncer/files/crowdsec-firewall-bouncer.initd7
2 files changed, 8 insertions, 1 deletions
diff --git a/net/crowdsec-firewall-bouncer/Makefile b/net/crowdsec-firewall-bouncer/Makefile
index ee8c73223..3f1464099 100644
--- a/net/crowdsec-firewall-bouncer/Makefile
+++ b/net/crowdsec-firewall-bouncer/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=crowdsec-firewall-bouncer
PKG_VERSION:=0.0.28
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/crowdsecurity/cs-firewall-bouncer/tar.gz/v$(PKG_VERSION)?
diff --git a/net/crowdsec-firewall-bouncer/files/crowdsec-firewall-bouncer.initd b/net/crowdsec-firewall-bouncer/files/crowdsec-firewall-bouncer.initd
index 04acd1617..eb5b79b7b 100755
--- a/net/crowdsec-firewall-bouncer/files/crowdsec-firewall-bouncer.initd
+++ b/net/crowdsec-firewall-bouncer/files/crowdsec-firewall-bouncer.initd
@@ -210,6 +210,13 @@ run_bouncer() {
procd_set_param command "$PROG" -c "$VARCONFIG"
procd_set_param stdout 1
procd_set_param stderr 1
+ procd_set_param nice 10
+ if [ -x "/sbin/ujail" ]; then
+ procd_add_jail cs-bouncer log
+ procd_add_jail_mount $VARCONFIG
+ procd_add_jail_mount_rw /var/log/
+ procd_set_param no_new_privs 1
+ fi
procd_close_instance
fi
}