aboutsummaryrefslogtreecommitdiff
path: root/net/conserver
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-08-25 15:03:21 -0400
committerRosen Penev <rosenp@gmail.com>2022-09-09 15:20:58 -0700
commit94f2484ac75fbce52a9d1439b3d7bfad75587fe7 (patch)
treee021ce3f9b6e867aa2d76ccffde23e2cc49770d3 /net/conserver
parentbaf45303bf6bd1385e64e6efbb2c7672b11e2891 (diff)
conserver: fix build with new autotools
Backport a patch that fixes build with new versions of Autoconf and Automake. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'net/conserver')
-rw-r--r--net/conserver/Makefile2
-rw-r--r--net/conserver/patches/000-100-backport-config-macro-fix.patch27
2 files changed, 28 insertions, 1 deletions
diff --git a/net/conserver/Makefile b/net/conserver/Makefile
index bfe851e81..ab3f39aac 100644
--- a/net/conserver/Makefile
+++ b/net/conserver/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=conserver
PKG_VERSION:=8.2.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/conserver/conserver/tar.gz/v$(PKG_VERSION)?
diff --git a/net/conserver/patches/000-100-backport-config-macro-fix.patch b/net/conserver/patches/000-100-backport-config-macro-fix.patch
new file mode 100644
index 000000000..e57a321fd
--- /dev/null
+++ b/net/conserver/patches/000-100-backport-config-macro-fix.patch
@@ -0,0 +1,27 @@
+From ce3b4f1d000c75ace2be2be83a0cc0df84ff6983
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 12 Jan 2021 18:18:23 +0100
+Subject: [PATCH] configure.ac: autoconf-2.70 fix
+
+Gentoo-bug: https://bugs.gentoo.org/750230
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,11 +30,11 @@ AH_TEMPLATE([TRUST_UDS_CRED], [Defined i
+
+ dnl ### Normal initialization. ######################################
+ AC_INIT([conserver],m4_esyscmd_s([./gen-version number]))
+-AC_PREREQ(2.59)
++AC_PREREQ(2.69)
+ AC_CONFIG_SRCDIR([conserver/main.c])
+ AC_CONFIG_HEADER(config.h)
+
+-AC_DEFINE_UNQUOTED(CONFIGINVOCATION, "$0 $@")
++AC_DEFINE_UNQUOTED(CONFIGINVOCATION, "$0 $*")
+
+ dnl ### Set some option defaults. ###################################
+ if test -z "$CFLAGS"; then