aboutsummaryrefslogtreecommitdiff
path: root/net/bwping
diff options
context:
space:
mode:
authorOleg Derevenetz <oleg-derevenetz@yandex.ru>2020-04-19 22:56:34 +0300
committerOleg Derevenetz <oleg-derevenetz@yandex.ru>2020-04-22 15:07:16 +0300
commit1515fad922349302d55ba3b3ed2ebad870eddb3f (patch)
treedc7333933694d6db18d5e0de78caa690d473cfe4 /net/bwping
parent56e9d83cf849aeafaa66c9494d24e75c8ba7d102 (diff)
bwping: add new package
Signed-off-by: Oleg Derevenetz <oleg-derevenetz@yandex.ru>
Diffstat (limited to 'net/bwping')
-rw-r--r--net/bwping/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/net/bwping/Makefile b/net/bwping/Makefile
new file mode 100644
index 000000000..33a19bd87
--- /dev/null
+++ b/net/bwping/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2020 Oleg Derevenetz <oleg.derevenetz@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bwping
+PKG_VERSION:=1.16
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/bwping
+PKG_HASH:=c0a0c61f779d7b497bfc264103614d013002e74502a868d678e8b569a3017687
+
+PKG_MAINTAINER:=Oleg Derevenetz <oleg.derevenetz@gmail.com>
+PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE_FILES:=COPYING
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bwping
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Tool to measure bandwidth and RTT between two hosts using ICMP
+ URL:=https://bwping.sourceforge.io/
+endef
+
+define Package/bwping/description
+ BWPing is a tool to measure bandwidth and response times between two
+ hosts using Internet Control Message Protocol (ICMP) echo request/echo
+ reply mechanism. It does not require any special software on the remote
+ host. The only requirement is the ability to respond on ICMP echo request
+ messages. BWPing supports both IPv4 and IPv6 networks.
+endef
+
+define Package/bwping/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/$(PKG_NAME) $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,bwping))