aboutsummaryrefslogtreecommitdiff
path: root/net/bonding
diff options
context:
space:
mode:
authorDENG Qingfang <dqfext@gmail.com>2021-07-16 16:28:51 +0800
committerLGA1150 <dqfext@gmail.com>2021-07-16 16:28:51 +0800
commite52f635c3627c61312fd2188d1c884aff0f8c71b (patch)
treed1cae6e164a4435e5a65fb74055e33f280354662 /net/bonding
parent9eb200f0d5293d96f41a30789fda3aee016dd64d (diff)
bonding: allow xmit_hash_policy in 802.3ad mode
Allow the transmit hash policy to be changed in 802.3ad mode. Signed-off-by: DENG Qingfang <dqfext@gmail.com>
Diffstat (limited to 'net/bonding')
-rw-r--r--net/bonding/Makefile2
-rwxr-xr-xnet/bonding/files/lib/netifd/proto/bonding.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/bonding/Makefile b/net/bonding/Makefile
index d3c1855f0..d9bafe21c 100644
--- a/net/bonding/Makefile
+++ b/net/bonding/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=proto-bonding
PKG_VERSION:=2021-04-09
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=
diff --git a/net/bonding/files/lib/netifd/proto/bonding.sh b/net/bonding/files/lib/netifd/proto/bonding.sh
index ac6551637..04cec109c 100755
--- a/net/bonding/files/lib/netifd/proto/bonding.sh
+++ b/net/bonding/files/lib/netifd/proto/bonding.sh
@@ -111,7 +111,7 @@ proto_bonding_setup() {
802.3ad)
echo "$bonding_policy" > /sys/class/net/"$link"/bonding/mode
- set_driver_values min_links ad_actor_sys_prio ad_actor_system ad_select lacp_rate
+ set_driver_values min_links ad_actor_sys_prio ad_actor_system ad_select lacp_rate xmit_hash_policy
;;
balance-rr)