aboutsummaryrefslogtreecommitdiff
path: root/net/bonding
diff options
context:
space:
mode:
authorHelge Mader <ma@dev.tdt.de>2020-03-02 14:39:45 +0100
committerHelge Mader <ma@dev.tdt.de>2020-03-03 11:28:43 +0100
commit6655654467a49f4c86c036bbb0d079a8fb6d52bd (patch)
tree006273f8635fe81524371e77fb946a1f5028bde1 /net/bonding
parentbca83b24a77428f26a8abcb93a1d095f07e6a9f1 (diff)
bonding: add missing policies
Signed-off-by: Helge Mader <ma@dev.tdt.de>
Diffstat (limited to 'net/bonding')
-rw-r--r--net/bonding/Makefile2
-rwxr-xr-xnet/bonding/files/lib/netifd/proto/bonding.sh9
2 files changed, 10 insertions, 1 deletions
diff --git a/net/bonding/Makefile b/net/bonding/Makefile
index 1c53fcb61..82543d242 100644
--- a/net/bonding/Makefile
+++ b/net/bonding/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=proto-bonding
-PKG_VERSION:=2018-06-11
+PKG_VERSION:=2020-03-03
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
diff --git a/net/bonding/files/lib/netifd/proto/bonding.sh b/net/bonding/files/lib/netifd/proto/bonding.sh
index b624738fe..5b106bc03 100755
--- a/net/bonding/files/lib/netifd/proto/bonding.sh
+++ b/net/bonding/files/lib/netifd/proto/bonding.sh
@@ -107,6 +107,15 @@ proto_bonding_setup() {
set_driver_values primary primary_reselect lp_interval tlb_dynamic_lb resend_igmp xmit_hash_policy
;;
+ balance-xor)
+ echo "$bonding_policy" > /sys/class/net/"$link"/bonding/mode
+ set_driver_values xmit_hash_policy
+ ;;
+
+ broadcast)
+ echo "$bonding_policy" > /sys/class/net/"$link"/bonding/mode
+ ;;
+
active-backup)
echo "$bonding_policy" > /sys/class/net/"$link"/bonding/mode
set_driver_values primary primary_reselect fail_over_mac num_grat_arp__num_unsol_na xmit_hash_policy