aboutsummaryrefslogtreecommitdiff
path: root/net/boinc/patches
diff options
context:
space:
mode:
authorSteffen Möller <moeller@debian.org>2020-04-08 00:44:31 +0200
committerN30dg <christian.dreihsig@t-online.de>2020-04-08 07:17:09 +0200
commite554dcf1d2d10597d617232508faebb58292724c (patch)
tree28ef06e67820d3fda46b7014f467349bad111b06 /net/boinc/patches
parentbdc23034ca061ad118f1031a5af7270a745498c5 (diff)
Boinc: Avoiding unexpected dependencies
In reaction to a comment by @hnyman in https://github.com/openwrt/packages/pull/11768#issuecomment-610513948 on BOINC embracing too many libraries it finds on its build host, the inclusion of the freetype library is now excluded by an embracing "if" statement. The patch is presented to BOINC upstream at https://github.com/BOINC/boinc/pull/3578 Signed-off-by: Steffen Möller <moeller@debian.org>
Diffstat (limited to 'net/boinc/patches')
-rw-r--r--net/boinc/patches/001-avoidExtraDependencies15
1 files changed, 15 insertions, 0 deletions
diff --git a/net/boinc/patches/001-avoidExtraDependencies b/net/boinc/patches/001-avoidExtraDependencies
new file mode 100644
index 000000000..ee914978b
--- /dev/null
+++ b/net/boinc/patches/001-avoidExtraDependencies
@@ -0,0 +1,15 @@
+Index: boinc-client_release-7.16-7.16.5/configure.ac
+===================================================================
+--- boinc-client_release-7.16-7.16.5.orig/configure.ac
++++ boinc-client_release-7.16-7.16.5/configure.ac
+@@ -506,8 +506,10 @@ SAH_CHECK_LIB([dl], [dlopen],
+ [BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
+ SAH_CHECK_LIB([nsl], [gethostbyname],
+ [BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
++if test "${enable_manager}" = yes ; then
+ SAH_CHECK_LIB([freetype], [fopen],
+ [BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
++fi
+ SAH_CHECK_LIB([socket], [bind],
+ [BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
+ SAH_CHECK_LIB([z], [gzopen],