aboutsummaryrefslogtreecommitdiff
path: root/net/boinc/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-02-21 17:46:13 -0800
committerRosen Penev <rosenp@gmail.com>2021-02-22 16:37:41 -0800
commitce361e3c1a2220f2c6d798ac1ca65dc57fdaff8b (patch)
tree2405502c82567384fafba8996ffdf35c38093a42 /net/boinc/patches
parent9543f72c7755e87686c5ac1e46565d8268d1d0ff (diff)
boinc: update to 7.16.16
Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/boinc/patches')
-rw-r--r--net/boinc/patches/001-avoidExtraDependencies2
-rw-r--r--net/boinc/patches/002-hosttypeRespected4
-rw-r--r--net/boinc/patches/010-openssl.patch31
3 files changed, 3 insertions, 34 deletions
diff --git a/net/boinc/patches/001-avoidExtraDependencies b/net/boinc/patches/001-avoidExtraDependencies
index e70997b49..ca46bef58 100644
--- a/net/boinc/patches/001-avoidExtraDependencies
+++ b/net/boinc/patches/001-avoidExtraDependencies
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -506,8 +506,10 @@ SAH_CHECK_LIB([dl], [dlopen],
+@@ -502,8 +502,10 @@ SAH_CHECK_LIB([dl], [dlopen],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
SAH_CHECK_LIB([nsl], [gethostbyname],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
diff --git a/net/boinc/patches/002-hosttypeRespected b/net/boinc/patches/002-hosttypeRespected
index b40271c08..35a3fb4ea 100644
--- a/net/boinc/patches/002-hosttypeRespected
+++ b/net/boinc/patches/002-hosttypeRespected
@@ -22,7 +22,7 @@
#if defined(_WIN32) && !defined(__CYGWIN32__)
#if defined(_WIN64) && defined(_M_X64)
add_platform("windows_x86_64");
-@@ -206,15 +221,6 @@ void CLIENT_STATE::detect_platforms() {
+@@ -210,15 +225,6 @@ void CLIENT_STATE::detect_platforms() {
add_platform("i686-pc-linux-gnu");
}
@@ -38,7 +38,7 @@
#elif defined(sun)
// Check if we can run 64-bit binaries...
// this assumes there isn't a 64-bit only solaris. (Every 64-bit solaris can run 32 bit binaries)
-@@ -290,6 +296,8 @@ void CLIENT_STATE::detect_platforms() {
+@@ -294,6 +300,8 @@ void CLIENT_STATE::detect_platforms() {
#endif
#endif
diff --git a/net/boinc/patches/010-openssl.patch b/net/boinc/patches/010-openssl.patch
deleted file mode 100644
index afe68d6c0..000000000
--- a/net/boinc/patches/010-openssl.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/lib/crypt.cpp
-+++ b/lib/crypt.cpp
-@@ -44,6 +44,7 @@
- #include <openssl/engine.h>
- #include <openssl/err.h>
- #include <openssl/rsa.h>
-+#include <openssl/bn.h>
-
- #ifdef _USING_FCGI_
- #include "boinc_fcgi.h"
-@@ -720,8 +721,10 @@ char *check_validity(
- int rbytes;
- unsigned char md5_md[MD5_DIGEST_LENGTH], rbuf[2048];
-
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(HAVE_LIBRESSL)
- SSL_load_error_strings();
- SSL_library_init();
-+#endif
-
- if (!is_file(origFile)) {
- return NULL;
-@@ -772,7 +775,9 @@ int cert_verify_file(
- fflush(stdout);
- return false;
- }
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(HAVE_LIBRESSL)
- SSL_library_init();
-+#endif
- if (!is_file(origFile)) return false;
- FILE* of = boinc_fopen(origFile, "r");
- if (!of) return false;