aboutsummaryrefslogtreecommitdiff
path: root/net/boinc/patches
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
committerIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
commit5d8d4fbbcb5c5de9370711c19bb3510210989a98 (patch)
treed0754921833f413b7eb93fb6bb1b1c8a22fb0498 /net/boinc/patches
parentd651082447b4392399a40ea1ae11d0bce4bfe83a (diff)
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset: find -L package/feeds/packages/ -name patches | \ sed 's/patches$/refresh/' | sort | xargs make Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Diffstat (limited to 'net/boinc/patches')
-rw-r--r--net/boinc/patches/001-avoidExtraDependencies6
-rw-r--r--net/boinc/patches/002-hosttypeRespected6
2 files changed, 4 insertions, 8 deletions
diff --git a/net/boinc/patches/001-avoidExtraDependencies b/net/boinc/patches/001-avoidExtraDependencies
index ee914978b..e70997b49 100644
--- a/net/boinc/patches/001-avoidExtraDependencies
+++ b/net/boinc/patches/001-avoidExtraDependencies
@@ -1,7 +1,5 @@
-Index: boinc-client_release-7.16-7.16.5/configure.ac
-===================================================================
---- boinc-client_release-7.16-7.16.5.orig/configure.ac
-+++ boinc-client_release-7.16-7.16.5/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -506,8 +506,10 @@ SAH_CHECK_LIB([dl], [dlopen],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
SAH_CHECK_LIB([nsl], [gethostbyname],
diff --git a/net/boinc/patches/002-hosttypeRespected b/net/boinc/patches/002-hosttypeRespected
index 6702b572e..b40271c08 100644
--- a/net/boinc/patches/002-hosttypeRespected
+++ b/net/boinc/patches/002-hosttypeRespected
@@ -1,7 +1,5 @@
-Index: boinc-client_release-7.16-7.16.6/client/cs_platforms.cpp
-===================================================================
---- boinc-client_release-7.16-7.16.6.orig/client/cs_platforms.cpp
-+++ boinc-client_release-7.16-7.16.6/client/cs_platforms.cpp
+--- a/client/cs_platforms.cpp
++++ b/client/cs_platforms.cpp
@@ -76,6 +76,21 @@ void CLIENT_STATE::add_platform(const ch
//
void CLIENT_STATE::detect_platforms() {