aboutsummaryrefslogtreecommitdiff
path: root/net/beanstalkd/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-04 15:51:58 -0700
committerRosen Penev <rosenp@gmail.com>2021-10-08 09:43:28 -0700
commit215a4f96ec07425777bf05a275099c6bfb17134b (patch)
tree55297dcec2d5a434b9e5cf3512ed0af622e1a716 /net/beanstalkd/Makefile
parent7a7d1a5d2cbf626119b4bc7598fdbe2d0afa3743 (diff)
beanstald: fix compilation under macOS
Makefile tests the host system, not what it compiles to. Override. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/beanstalkd/Makefile')
-rw-r--r--net/beanstalkd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/beanstalkd/Makefile b/net/beanstalkd/Makefile
index 3bedb09bc..97c2608eb 100644
--- a/net/beanstalkd/Makefile
+++ b/net/beanstalkd/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=beanstalkd
PKG_VERSION:=1.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
# for now, build from latest commit since releases are infrequent and
# useful fixes trickle in...
@@ -37,7 +37,7 @@ define Build/Configure
endef
define Build/Compile
- cd $(PKG_BUILD_DIR) && make CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" PREFIX=/usr
+ cd $(PKG_BUILD_DIR) && make CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" PREFIX=/usr OS=linux
endef
define Package/beanstalkd/install