aboutsummaryrefslogtreecommitdiff
path: root/net/autossh
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-12 18:26:19 -0700
committerRosen Penev <rosenp@gmail.com>2021-06-12 20:15:33 -0700
commit63b7febf5f62a120539611b1f7c252db5dc244cb (patch)
tree9a3a88deadc58391f139d897914463da44f5bfc8 /net/autossh
parente2d9e874dc1d15a0fa94846c0d186c89dfc8bc29 (diff)
autossh: fix compilation without ssh installed
configure script looks for host ssh. Just pass the configure variable directly. --with-ssh doesn't work. Also get rid of custom Compile section. It's not needed. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/autossh')
-rw-r--r--net/autossh/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/net/autossh/Makefile b/net/autossh/Makefile
index 78dc90eca..87fd91347 100644
--- a/net/autossh/Makefile
+++ b/net/autossh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=autossh
PKG_VERSION:=1.4g
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://www.harding.motd.ca/autossh/
@@ -27,12 +27,8 @@ define Package/autossh
SUBMENU:=SSH
endef
-define Build/Compile
- $(call Build/Compile/Default, -f Makefile \
- CFLAGS="$(TARGET_CFLAGS) -Wall -D\"SSH_PATH=\\\"\$$$$(SSH)\\\"\" -D\"VER=\\\"\$$$$(VER)\\\"\"" \
- all \
- )
-endef
+CONFIGURE_VARS += \
+ ac_cv_path_ssh=/usr/bin/ssh
define Package/autossh/install
$(INSTALL_DIR) $(1)/usr/sbin