aboutsummaryrefslogtreecommitdiff
path: root/net/autossh
diff options
context:
space:
mode:
authorkkubicki <krzysiek.kubicki@gmail.com>2024-01-12 21:26:17 +0000
committerRosen Penev <rosenp@gmail.com>2024-02-07 14:11:35 -0800
commit278970f10c9911ff557b0838645cc285f835c9f6 (patch)
tree10d9fb2ecddab50e0d09dacf34cea9b866176acc /net/autossh
parentb94c6dd37df76aa7f6b6813135228b82cd5d8886 (diff)
autossh: make forwarding optional
- previously localport option was required, which broke older configs - now in-config forwarding is only optional - ssh option still can be used for forwarding as in sample config Signed-off-by: kkubicki <krzysiek.kubicki@gmail.com>
Diffstat (limited to 'net/autossh')
-rw-r--r--net/autossh/Makefile2
-rw-r--r--net/autossh/files/autossh.init16
2 files changed, 9 insertions, 9 deletions
diff --git a/net/autossh/Makefile b/net/autossh/Makefile
index 9889378f8..6bf2a1dda 100644
--- a/net/autossh/Makefile
+++ b/net/autossh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=autossh
PKG_VERSION:=1.4g
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://www.harding.motd.ca/autossh/
diff --git a/net/autossh/files/autossh.init b/net/autossh/files/autossh.init
index 0e7b08666..2c1890532 100644
--- a/net/autossh/files/autossh.init
+++ b/net/autossh/files/autossh.init
@@ -34,17 +34,17 @@ start_instance() {
config_get path "$section" path
config_get pidfile "$section" pidfile
- if [ -z "$localport" ]; then
- echo "autossh: localport option is required"
+ if [ -n "$localport" ] && [ -n "$remoteport" ]; then
+ if [ -n "$remotehost" ]; then
+ forwarding="-L ${localport}:${remotehost}:${remoteport}"
+ else
+ forwarding="-R ${remoteport}:${localhost}:${localport}"
+ fi
+ elif [ -n "$localport" ] || [ -n "$remoteport" ]; then
+ echo "autossh: both localport and remoteport options are required"
return 1
fi
- if [ -n "$remotehost" ]; then
- forwarding="-L ${localport}:${remotehost}:${remoteport}"
- else
- forwarding="-R ${remoteport}:${localhost}:${localport}"
- fi
-
procd_open_instance "$section"
procd_set_param command /usr/sbin/autossh ${forwarding} ${ssh}
procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-5}