aboutsummaryrefslogtreecommitdiff
path: root/net/autossh/Makefile
diff options
context:
space:
mode:
authorChristian Beier <cb@shoutrlabs.com>2016-09-06 13:51:24 +0200
committerChristian Beier <cb@shoutrlabs.com>2016-09-06 13:51:24 +0200
commit0648e9e71e37f874188bd860d5e402c43b37ea3a (patch)
tree460546333ff833554c639e2a7eb208b34f456a16 /net/autossh/Makefile
parent6432150acc4f56b0256b02e2b4da4f4c5e59b7cb (diff)
autossh: import from oldpackages
Signed-off-by: Christian Beier <cb@shoutrlabs.com>
Diffstat (limited to 'net/autossh/Makefile')
-rw-r--r--net/autossh/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/net/autossh/Makefile b/net/autossh/Makefile
new file mode 100644
index 000000000..ec6e7eb11
--- /dev/null
+++ b/net/autossh/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=autossh
+PKG_VERSION:=1.4b
+PKG_RELEASE:=6
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://www.harding.motd.ca/autossh/
+PKG_MD5SUM:=8f9aa006f6f69e912d3c2f504622d6f7
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/autossh
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Autossh client
+ URL:=http://www.harding.motd.ca/autossh/
+ SUBMENU:=SSH
+endef
+
+define Build/Compile
+ $(call Build/Compile/Default, -f Makefile \
+ CFLAGS="$(TARGET_CFLAGS) -Wall -D\"SSH_PATH=\\\"\$$$$(SSH)\\\"\" -D\"VER=\\\"\$$$$(VER)\\\"\"" \
+ all \
+ )
+endef
+
+define Package/autossh/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/autossh $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/autossh.init $(1)/etc/init.d/autossh
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_DATA) ./files/autossh.config $(1)/etc/config/autossh
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/autossh.hotplug $(1)/etc/hotplug.d/iface/20-autossh
+endef
+
+define Package/autossh/conffiles
+/etc/config/autossh
+endef
+
+$(eval $(call BuildPackage,autossh))