aboutsummaryrefslogtreecommitdiff
path: root/net/apinger/Makefile
diff options
context:
space:
mode:
authorAlex Samorukov <samm@os2.kiev.ua>2015-04-08 17:07:52 +0000
committerAlex Samorukov <samm@os2.kiev.ua>2015-04-08 17:07:52 +0000
commit11e83c69281842975db5c49664f20c1c2d08441a (patch)
tree8030f8c5fb1839745623778ad0cd54829cacbf18 /net/apinger/Makefile
parentf64a24267c7b27a80170e2d3cbeae0dc1b786e81 (diff)
apinger: add apinger package
Alarm Pinger (apinger) is a little tool which monitors various IP devices by simple ICMP echo requests. There are various other tools, that can do this, but most of them are shell or perl scripts, spawning many processes, thus much CPU-expensive, especially when one wants continuous monitoring and fast response on target failure. Signed-off-by: Alex Samorukov <samm@os2.kiev.ua>
Diffstat (limited to 'net/apinger/Makefile')
-rw-r--r--net/apinger/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/net/apinger/Makefile b/net/apinger/Makefile
new file mode 100644
index 000000000..5d73ae1bf
--- /dev/null
+++ b/net/apinger/Makefile
@@ -0,0 +1,67 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=apinger
+PKG_VERSION:=0.6.1
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/Jajcus/apinger.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=c7da72f7ec26eedd7fd8d224c0e10787b204f94e
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+
+PKG_MAINTAINER:=Alex Samorukov <samm@os2.kiev.ua>
+PKG_LICENSE:= GPL-2.0
+
+PKG_FIXUP:=autoreconf
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/apinger
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Tool which monitors various IP devices by simple ICMP echo requests
+ URL:=https://github.com/Jajcus/apinger
+ PKG_MAINTAINER:=Alex Samorukov <samm@os2.kiev.ua>
+endef
+
+define Package/apinger/description
+ Alarm Pinger (apinger) is a little tool which monitors various IP devices by
+ simple ICMP echo requests. There are various other tools, that can do this,
+ but most of them are shell or perl scripts, spawning many processes, thus much
+ CPU-expensive, especially when one wants continuous monitoring and fast
+ response on target failure. Alarm Pinger is a single program written in C, so
+ it doesn't need much CPU power even when monitoring many targets with frequent
+ probes. Alarm Pinger supports both IPv4 and IPv6. The code have been tested
+ on Linux and FreeBSD.
+endef
+
+define Package/apinger/conffiles
+/etc/apinger.conf
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default)
+endef
+
+define Package/apinger/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/apinger $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/src/apinger.conf $(1)/etc/apinger.conf
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/apinger.init $(1)/etc/init.d/apinger
+endef
+
+$(eval $(call BuildPackage,apinger))
+