aboutsummaryrefslogtreecommitdiff
path: root/net/apfree-wifidog
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-02 16:50:07 -0700
committerRosen Penev <rosenp@gmail.com>2020-07-02 19:16:30 -0700
commit1c4fb05ba385155369a64e8104baeedb826b944d (patch)
treedc41810907d5e5d4eff59041ad7ff29c8f6c99f3 /net/apfree-wifidog
parent371d7b3892ee596bbb2e68a28ed2c41c218730cb (diff)
apfree-wifidog: fix compilation with GCC10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/apfree-wifidog')
-rw-r--r--net/apfree-wifidog/Makefile2
-rw-r--r--net/apfree-wifidog/patches/020-gcc10.patch36
2 files changed, 37 insertions, 1 deletions
diff --git a/net/apfree-wifidog/Makefile b/net/apfree-wifidog/Makefile
index 370ba70b6..1c5491917 100644
--- a/net/apfree-wifidog/Makefile
+++ b/net/apfree-wifidog/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=apfree-wifidog
PKG_VERSION:=3.11.1716
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/liudf0716/apfree_wifidog.git
diff --git a/net/apfree-wifidog/patches/020-gcc10.patch b/net/apfree-wifidog/patches/020-gcc10.patch
new file mode 100644
index 000000000..0fd1476d1
--- /dev/null
+++ b/net/apfree-wifidog/patches/020-gcc10.patch
@@ -0,0 +1,36 @@
+--- a/src/conf.h
++++ b/src/conf.h
+@@ -430,12 +430,12 @@ void clear_trusted_ip_list(void);
+ void del_trusted_ip_list(const char *);
+
+ // online clients
+-int g_online_clients; // total connected client count
+-char *g_version;
+-char *g_type; // hardware type
+-char *g_name; // firmware name
+-char *g_channel_path;
+-char *g_ssid;
++extern int g_online_clients; // total connected client count
++extern char *g_version;
++extern char *g_type; // hardware type
++extern char *g_name; // firmware name
++extern char *g_channel_path;
++extern char *g_ssid;
+
+ #define LOCK_DOMAIN() do { \
+ debug(LOG_INFO, "Locking domain"); \
+--- a/src/ping_thread.c
++++ b/src/ping_thread.c
+@@ -43,6 +43,12 @@
+ #include "wd_client.h"
+
+ extern time_t started_time;
++int g_online_clients;
++char *g_version;
++char *g_type;
++char *g_name;
++char *g_channel_path;
++char *g_ssid;
+
+ static void fw_init_delay();
+ static void ping_work_cb(evutil_socket_t, short, void *);