aboutsummaryrefslogtreecommitdiff
path: root/net/apcupsd
diff options
context:
space:
mode:
authorIvan Pavlov <AuthorReflex@gmail.com>2024-04-03 21:57:40 +0300
committerRosen Penev <rosenp@gmail.com>2024-04-03 15:57:01 -0700
commit98a5367982a6c0e1ab765886db0d575564274664 (patch)
treec085e0c23f16e27bd32c8830be3eec592d2c79e6 /net/apcupsd
parent2383185c3152ae6eb30468f14794b73b71ab05fb (diff)
apcupsd: fix gcc 13 compliation error
On GCC13 build fails: toolchain-mipsel_24kc_gcc-13.2.0_musl/lib/libsupc++.a(eh_alloc.o): in function `std::__sv_check(unsigned int, unsigned int, char const*)': toolchain-mipsel_24kc_gcc-13.2.0_musl/gcc-13.2.0-final/mipsel-openwrt-linux-musl/libstdc++-v3/include/string_view:73: undefined reference to `std::__throw_out_of_range_fmt(char const*, ...)' collect2: error: ld returned 1 exit status make[5]: *** [Makefile:33: apcupsd] Error 1 Workaround found at https://lore.kernel.org/buildroot/87wmsbk386.fsf@48ers.dk/T/ Signed-off-by: Ivan Pavlov <AuthorReflex@gmail.com>
Diffstat (limited to 'net/apcupsd')
-rw-r--r--net/apcupsd/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/apcupsd/Makefile b/net/apcupsd/Makefile
index b63972082..b765b583f 100644
--- a/net/apcupsd/Makefile
+++ b/net/apcupsd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=apcupsd
PKG_VERSION:=3.14.14
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
PKG_LICENSE:=GPL-2.0
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/apcupsd
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+libpthread +libusb-compat
+ DEPENDS:=+libpthread +libusb-compat +libstdcpp
TITLE:=UPS control software
URL:=http://www.apcupsd.org/
endef
@@ -35,7 +35,7 @@ endef
define Package/apcupsd-cgi
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+libpthread +libgd
+ DEPENDS:=+libpthread +libgd +libstdcpp
TITLE:=UPS control software CGI module
URL:=http://www.apcupsd.org/
endef
@@ -57,7 +57,7 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- LD="$(TARGET_CC)" \
+ LD="$(TARGET_CXX)" \
all install
endef