aboutsummaryrefslogtreecommitdiff
path: root/net/apache/Makefile
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2021-10-24 15:36:22 +0200
committerRosen Penev <rosenp@gmail.com>2021-10-26 09:39:53 -0700
commit83d1cdaf3f1392a67aaa9d10f544680805229019 (patch)
tree335a698ae462e1f377505bd3d68500966c46ba9a /net/apache/Makefile
parentda4b1ca8d65b788d85489cd3ca83d91b0fd72f0f (diff)
apache: fixup apxs
apxs is used to get information about the apache installation when building external modules. Currently there are issues: 1. ./staging_dir/target-mips_24kc_musl/usr/bin/apxs -q TARGET apache2 apxs:Error: ./staging_dir/target-mips_24kc_musl/home/sk/tmp/openwrt/staging_dir/target-mips_24kc_musl/usr/bin/apr-1-config not found!. This error is fixed by sed script #2. 2. ./staging_dir/target-mips_24kc_musl/usr/bin/apxs -q TARGET cannot open ./staging_dir/target-mips_24kc_musl/home/sk/tmp/openwrt/staging_dir/target-mips_24kc_musl/usr/share/apache2/build/config_vars.mk: No such file or directory at ./staging_dir/target-mips_24kc_musl/usr/bin/apxs line 213. This error is fixed by sed scipt #1. Both sed scripts taken from buildroot (see [1]). [1] https://github.com/buildroot/buildroot/blob/master/package/apache/apache.mk Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'net/apache/Makefile')
-rw-r--r--net/apache/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/net/apache/Makefile b/net/apache/Makefile
index 35c648189..d3c6d89a4 100644
--- a/net/apache/Makefile
+++ b/net/apache/Makefile
@@ -282,6 +282,9 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/share/apache2/build
$(CP) $(PKG_INSTALL_DIR)/usr/share/apache2/build/* \
$(1)/usr/share/apache2/build
+ $(SED) 's%"/usr/bin"%"$(STAGING_DIR)/usr/bin"%' $(1)/usr/bin/apxs
+ $(SED) 's%/usr/share/apache2/build%$(STAGING_DIR)/usr/share/apache2/build%' \
+ $(1)/usr/bin/apxs
$(SED) 's%^prefix =.*%prefix = $(STAGING_DIR)/usr%' \
$(1)/usr/share/apache2/build/config_vars.mk
endef