aboutsummaryrefslogtreecommitdiff
path: root/net/apache/Makefile
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2020-01-01 23:19:02 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2020-01-01 23:20:24 +0100
commit14f4f0bef0448d950cf1371de3a05f302a2779c8 (patch)
treeb1554a6372570f29da44186305e64e5053541f9f /net/apache/Makefile
parent7b6e55e200b0f729fa18b4e57987237cf1989de7 (diff)
apache: bump to 2.4.41
- version bump - update license description - add PKG_BUILD_PARALLEL:=1 - remove two cross-compile patches and replace them with the cross-compile patch from buildroot (adds autoreconf to get this going) Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'net/apache/Makefile')
-rw-r--r--net/apache/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/net/apache/Makefile b/net/apache/Makefile
index 1dd22bdb8..234ffca29 100644
--- a/net/apache/Makefile
+++ b/net/apache/Makefile
@@ -8,25 +8,31 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=apache
-PKG_VERSION:=2.4.37
-PKG_RELEASE:=2
+PKG_VERSION:=2.4.41
+PKG_RELEASE:=1
PKG_SOURCE_NAME:=httpd
PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@APACHE/httpd/
-PKG_HASH:=3498dc5c6772fac2eb7307dc7963122ffe243b5e806e0be4fb51974ff759d726
+PKG_HASH:=133d48298fe5315ae9366a0ec66282fa4040efa5d566174481077ade7d18ea40
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
-PKG_LICENSE:=Apache License
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
PKG_CPE_ID:=cpe:/a:apache:http_server
+PKG_BUILD_PARALLEL:=1
+
PKG_INSTALL:=1
PKG_CONFIG_DEPENDS:= \
CONFIG_APACHE_HTTP2
+PKG_FIXUP:=autoreconf
+
ADDITIONAL_MODULES:=
ifeq ($(CONFIG_APACHE_HTTP2),y)
ADDITIONAL_MODULES += --enable-http2