aboutsummaryrefslogtreecommitdiff
path: root/net/aircrack-ng
diff options
context:
space:
mode:
authorRick Farina (Zero_Chaos) <zerochaos@gentoo.org>2015-02-07 14:13:53 -0500
committerRick Farina (Zero_Chaos) <zerochaos@gentoo.org>2015-02-07 14:15:41 -0500
commita9bc9391662492174fb2c7247499e38d188ca077 (patch)
treee537c6ed894a1535cebcef8d7ade0b0a6a4706de /net/aircrack-ng
parent2b198b27ee172471768c0459cbf60e0a70a6a1a7 (diff)
aircrack-ng: import from old packages
cleanup, update to latest version, mark myself maintainer Signed-off-by: Rick Farina (Zero_Chaos) <zerochaos@gentoo.org>
Diffstat (limited to 'net/aircrack-ng')
-rw-r--r--net/aircrack-ng/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/net/aircrack-ng/Makefile b/net/aircrack-ng/Makefile
new file mode 100644
index 000000000..960ef856f
--- /dev/null
+++ b/net/aircrack-ng/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aircrack-ng
+PKG_VERSION:=1.2-rc1
+PKG_RELEASE:=1
+PKG_LICENSE:=GPLv2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.aircrack-ng.org/ \
+ http://archive.aircrack-ng.org/aircrack-ng/$(PKG_VERSION)/
+PKG_MD5SUM:=c2f8648c92f7e46051c86c618d4fb0d5
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/aircrack-ng
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libpcap +libpthread +libopenssl +libnl +wireless-tools +ethtool
+ TITLE:=WLAN tools for breaking 802.11 WEP/WPA keys
+ URL:=http://www.aircrack-ng.org/
+ MAINTAINER:=Rick Farina <zerochaos@gentoo.org>
+ SUBMENU:=wireless
+endef
+
+define Package/aircrack-ng/description
+ WLAN tools for breaking 802.11 WEP/WPA keys
+endef
+
+MAKE_FLAGS += prefix=/usr \
+ libnl=true \
+ sqlite=false \
+ unstable=false \
+ OSNAME=Linux
+
+define Package/aircrack-ng/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,aircrack-ng))