aboutsummaryrefslogtreecommitdiff
path: root/net/aircrack-ng
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-10-01 00:43:21 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-01 00:43:21 +0200
commit41922f33b5f2cbc58e504469cdcd14ffa33ee5f3 (patch)
treea911d01e479aedc8a0529f67be44a39c5c515b09 /net/aircrack-ng
parent002ff0dd11ffaab73bcd3034e2f82a2c5f396e09 (diff)
aircrack-ng: bump to release 1.7
Bump aircrack-ng to release 1.7 Changelog from [1] Airdecap-ng: Endianness fixes Airdecap-ng: Output PCAP as little endian Airodump-ng: Fixed blank encryption field when APs have TKIP (and/or CCMP) with WPA2 Airodump-ng: Updated encryption filter (-t/--encrypt) for WPA3 and OWE Airodump-ng: Fixed out-of-order timestamp captures Airodump-ng: Ignore NULL PMKID Airodump-ng: Fixed dropping management frames with zeroed timestamp Airodump-ng: Fixed sorting where sometimes it started with a different field Airodump-ng: Allow setting colors only in AP selection mode Airodump-ng: Fix crash on 4K Linux console Airodump-ng: Fixed issue where existing clients not linked to an AP become hidden when hitting 'o' Airodump-ng: Allow use of WiFi 6E 6GHz frequencies Airodump-ng: Look for oui.txt in /usr/share/hwdata Airgraph-ng: Fixed graphviz package conflict Airgraph-ng: Fixed downloading OUI with python3 Airgraph-ng: Ensure support/ directory is created when installing Aircrack-ng: Fixed static compilation Aircrack-ng: Fix handshake replay counter logic Aircrack-ng: Handle timeout when parsing EAPOL Aircrack-ng: Fixed WEP display Aircrack-ng: Fixed spurious EXIT messages Aircrack-ng: Improved handshake selection by fixing EAPOL timing and clearing state Aircrack-ng: Ignore NULL PMKID Aircrack-ng: Added Apple M1 detection Aireplay-ng: In test mode, detect tampering of sequence number by firmware/driver Aireplay-ng: Fixed incorrectly rewritten loops affecting fragmentation attack, and in some cases, SKA fake auth Aireplay-ng: Fixed a bunch of instances where packets had their duration updated instead of the sequence number Airmon-ng: Fix avahi killing Airmon-ng: rewrite service stopping entirely Airmon-ng: Codestyle fixes and code cleanup Airmon-ng: Added a few Raspberry Pi hardware revisions Airmon-ng: Fixes for 8812au driver Airmon-ng: Fix iwlwifi firmware formatting Airmon-ng: Remove broken KVM detection Airmon-ng: Show regdomain in verbose mode Airmon-ng: Updated Raspberry Pi hardware revisions Airmon-ng: Document frequency usage Airmon-ng: Add a sleep to help predictable names due to udev sometimes renaming interface Airmon-ng: Added warning for broken radiotap headers in kernel 5.15 to 5.15.4 Airmon-ng: shellcheck fixes Airmon-ng: support systemctl as some systems don't support 'service' anymore Airmon-ng: Fixes for pciutils 3.8, backward compatible Airbase-ng: use enum for frame type/subtype Airbase-ng: remove a few IE in association responses Besside-ng: Support and detect all channels in 5GHz in Auto-Channel mode OSdep: Search additional IE for channel information OSdep: Android macro fixes Patches: Add missing patches that were on https://patches.aircrack-ng.org but not in repo Patches: Updated freeradius-wpe patch for v3.2.0 Patches: Updated hostapd-wpe patch for v2.10 Patches: Added docker containers to test WPE patches Autotools: make dist now creates VERSION file Autotools: Added maintainer mode Autotools: Initial support for Link Time Optimization (LTO) builds Integration tests: Added a new test, and improved some existing ones Airgraph-ng: switch airodump-join to Python 3 Manpages: Fixes (typos, tools name, etc.) and improvements README: Updated dependencies and their installation on various distros in README.md and INSTALLING README: Fixed typos and spelling in README.md and INSTALLING Packages: Packages on PackageCloud now support any distro using .deb and .rpm, however, it requires reinstalling repo (BREAKING CHANGE) General: Fix compilation with LibreSSL 3.5 General: Fix issues reported by Infer General: Updated buildbots General: Add Linux uclibc support General: Compilation fixes on macOS with the Apple M1 CPU General: Removed TravisCI and AppVeyor General: Use Github Actions for CI (Linux, Win, macOS, code style, and PVS-Studio) General: Added vscode devcontainer and documentation General: Fix warnings from PVS-Studio and build with pedantic (See PR2174) General: Shell script fixes thanks to shellcheck General: Fixes for GCC 10 and 11 General: Fixed cross-compilation General: Code refactoring, deduplication, cleanup, and misc code improvements General: Coverity Scan fixes, which includes memory leaks, race conditions, division by 0, and other issues General: PVS Studio improvements,fixes and updates General: Code formatting/style fixes General: Various fixes and improvements (code, CI, integration tests, coverity) General: Update bug reporting template and update the process [1] https://aircrack-ng.blogspot.com/2022/05/aircrack-ng-17.html Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'net/aircrack-ng')
-rw-r--r--net/aircrack-ng/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/aircrack-ng/Makefile b/net/aircrack-ng/Makefile
index 1323a0e6b..34ec2055e 100644
--- a/net/aircrack-ng/Makefile
+++ b/net/aircrack-ng/Makefile
@@ -8,15 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=aircrack-ng
-PKG_VERSION:=1.6
-PKG_RELEASE:=3
+PKG_VERSION:=1.7
+PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:aircrack-ng:aircrack-ng
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.aircrack-ng.org/
-PKG_HASH:=4f0bfd486efc6ea7229f7fbc54340ff8b2094a0d73e9f617e0a39f878999a247
+PKG_HASH:=05a704e3c8f7792a17315080a21214a4448fd2452c1b0dd5226a3a55f90b58c3
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1