aboutsummaryrefslogtreecommitdiff
path: root/net/aircrack-ng
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-03-14 19:26:13 -0700
committerGitHub <noreply@github.com>2018-03-14 19:26:13 -0700
commit2e9933919187e40431d8097cd51d846806e5fb42 (patch)
treeb0d0488270d952d9e9d39ddd3901f00847055e60 /net/aircrack-ng
parenta296a374c63d5316e167bf0845fbea704995c017 (diff)
aircrack-ng: Add -std=gnu89 to fix compile issues.
The code assumes pre-C99 inlining. This causes issues with GCC7 which assumes C11. Add std=gnu89 to restore proper behavior. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/aircrack-ng')
-rw-r--r--net/aircrack-ng/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/aircrack-ng/Makefile b/net/aircrack-ng/Makefile
index 5c8f0340c..7e472fb3c 100644
--- a/net/aircrack-ng/Makefile
+++ b/net/aircrack-ng/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=aircrack-ng
PKG_VERSION:=1.2-rc1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -51,6 +51,8 @@ define Package/airmon-ng/description
Bash script designed to turn wireless cards into monitor mode.
endef
+TARGET_CFLAGS += -std=gnu89
+
MAKE_FLAGS += prefix=/usr \
libnl=true \
sqlite=false \