aboutsummaryrefslogtreecommitdiff
path: root/net/aggregate
diff options
context:
space:
mode:
authorAlexander Ryzhov <github@ryzhov-al.ru>2019-01-23 10:06:32 +0300
committerAlexander Ryzhov <github@ryzhov-al.ru>2019-01-23 10:06:32 +0300
commit7454478df3fb1c8775e9f89309a65eebef187512 (patch)
treeda3faa0bfc625a8322f52c07cce0e810c7b65ce3 /net/aggregate
parent49e441c259d894f6e756739dce9577d45a7eb213 (diff)
aggregate: respect CFLAGS, LDFLAGS
Signed-off-by: Alexander Ryzhov <github@ryzhov-al.ru>
Diffstat (limited to 'net/aggregate')
-rw-r--r--net/aggregate/Makefile2
-rw-r--r--net/aggregate/patches/500-cross_compile_flags.patch14
2 files changed, 15 insertions, 1 deletions
diff --git a/net/aggregate/Makefile b/net/aggregate/Makefile
index 1eb3d2ee7..c20f95bae 100644
--- a/net/aggregate/Makefile
+++ b/net/aggregate/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=aggregate
PKG_VERSION:=1.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.isc.org/isc/aggregate/
diff --git a/net/aggregate/patches/500-cross_compile_flags.patch b/net/aggregate/patches/500-cross_compile_flags.patch
new file mode 100644
index 000000000..b7392fbb0
--- /dev/null
+++ b/net/aggregate/patches/500-cross_compile_flags.patch
@@ -0,0 +1,14 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -25,8 +25,9 @@
+ INSTALL = @INSTALL@
+ DEFS = @DEFS@
+ LIBS = @LIBS@
+-CFLAGS = -O
+-LDFLAGS = -s
++CFLAGS = @CFLAGS@
++CPPFLAGS = @CPPFLAGS@
++LDFLAGS = @LDFLAGS@
+ prefix = @prefix@
+
+ SHELL = /bin/sh