aboutsummaryrefslogtreecommitdiff
path: root/net/aggregate/Makefile
diff options
context:
space:
mode:
authorNikil Mehta <nikil.mehta@gmail.com>2016-11-23 12:01:21 -0800
committerNikil Mehta <nikil.mehta@gmail.com>2016-11-26 01:34:28 -0800
commit631ca3af76d727f5b772efaa8a911d36b73b56ec (patch)
treefaa2b9eb61b6513b911ffebf04a314fab6e5ac9c /net/aggregate/Makefile
parent2eb0eaa77441d46a6d54bc5f4f2b11f2f88b00ed (diff)
aggregate: Add package
Signed-off-by: Nikil Mehta <nikil.mehta@gmail.com>
Diffstat (limited to 'net/aggregate/Makefile')
-rw-r--r--net/aggregate/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/net/aggregate/Makefile b/net/aggregate/Makefile
new file mode 100644
index 000000000..0127285c9
--- /dev/null
+++ b/net/aggregate/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2006-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aggregate
+PKG_VERSION:=1.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://ftp.isc.org/isc/aggregate/
+PKG_MD5SUM:=6fcc515388bf2c5b0c8f9f733bfee7e1
+
+PKG_MAINTAINER:=Nikil Mehta <nikil.mehta@gmail.com>
+PKG_LICENSE:=ISC
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/aggregate
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=IP Addresses and Names
+ TITLE:=ipv4 cidr prefix aggregator
+ URL:=https://ftp.isc.org/isc/aggregate/
+endef
+
+define Package/aggregate/description
+ takes a list of prefixes in conventional format on stdin, and performs two
+ optimisations to reduce the length of the prefix list. It removes any
+ supplied prefixes which are supurfluous because they are already included in
+ another supplied prefix (e.g., 203.97.2.0/24 would be removed if
+ 203.97.0.0/17 was also supplied), and identifies adjacent prefixes that can
+ be combined under a single, shorter-length prefix (e.g., 203.97.2.0/24 and
+ 203.97.3.0/24 can be combined into the single prefix 203.97.2.0/23).
+endef
+
+define Package/aggregate/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/aggregate $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,aggregate))