aboutsummaryrefslogtreecommitdiff
path: root/net/adguardhome
diff options
context:
space:
mode:
authorDobroslaw Kijowski <dobo90@gmail.com>2023-03-08 09:46:14 +0100
committerTianling Shen <cnsztl@gmail.com>2023-03-08 23:11:57 +0800
commit2e68b9f51547cff76dc0b74ab0729961333839fa (patch)
tree83894e3a638c94786c372efed0e4694f10891ac5 /net/adguardhome
parentd71c26c7af61fbdcf22231cb182987bf1fe66853 (diff)
adguardhome: enable legacy openssl provider for nodejs
Currently compilation fails because of: ``` opensslErrorStack: [ 'error:03000086:digital envelope routines::initialization error' ], library: 'digital envelope routines', reason: 'unsupported', code: 'ERR_OSSL_EVP_UNSUPPORTED' ``` What's interesting package gets built but when trying to access UI there's `404: page not found` error. It has been reported in multiple places: * https://github.com/AdguardTeam/AdGuardHome/issues/5559 * https://github.com/AdguardTeam/AdGuardHome/issues/4595 Signed-off-by: Dobroslaw Kijowski <dobo90@gmail.com>
Diffstat (limited to 'net/adguardhome')
-rw-r--r--net/adguardhome/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/adguardhome/Makefile b/net/adguardhome/Makefile
index 309ffec6c..0ffe81deb 100644
--- a/net/adguardhome/Makefile
+++ b/net/adguardhome/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=adguardhome
PKG_VERSION:=0.107.24
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
@@ -56,7 +56,7 @@ endef
define Build/Compile
( \
pushd $(PKG_BUILD_DIR) ; \
- make js-deps js-build ; \
+ NODE_OPTIONS=--openssl-legacy-provider make js-deps js-build ; \
popd ; \
$(call GoPackage/Build/Compile) ; \
)