aboutsummaryrefslogtreecommitdiff
path: root/net/adblock
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2017-07-05 18:46:08 +0200
committerDirk Brenken <dev@brenken.org>2017-07-05 18:46:08 +0200
commitd51f38672a27e4c094dfe750d2b38eaa10ab21ab (patch)
treedc60a33c58be40a3948ccfbce71d8096bd9b4b5e /net/adblock
parentacafc3c40e31e3187fa88e3a1fde6d2047c1d461 (diff)
adblock: update 2.8.3
* refine manual/backup mode (exclude local blacklist processing) * cosmetics Signed-off-by: Dirk Brenken <dev@brenken.org>
Diffstat (limited to 'net/adblock')
-rw-r--r--net/adblock/Makefile2
-rwxr-xr-xnet/adblock/files/adblock.sh6
2 files changed, 4 insertions, 4 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index 4b387977e..eca17098f 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
-PKG_VERSION:=2.8.2
+PKG_VERSION:=2.8.3
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/adblock.sh b/net/adblock/files/adblock.sh
index 7c3112877..0478f84a9 100755
--- a/net/adblock/files/adblock.sh
+++ b/net/adblock/files/adblock.sh
@@ -10,7 +10,7 @@
#
LC_ALL=C
PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_ver="2.8.2"
+adb_ver="2.8.3"
adb_sysver="$(ubus -S call system board | jsonfilter -e '@.release.description')"
adb_enabled=1
adb_debug=0
@@ -462,7 +462,7 @@ f_main()
# manual mode
#
- if [ ${adb_manmode} -eq 1 ] && [ -z "${adb_action}" ]
+ if [ ${adb_manmode} -eq 1 ] && [ -z "${adb_action}" ] && [ "${src_name}" != "blacklist" ]
then
f_list restore
if [ ${adb_rc} -eq 0 ] && [ -s "${adb_tmpfile}" ]
@@ -535,7 +535,7 @@ f_main()
fi
done
- # hash preparation & overall sort
+ # hash preparation and overall sort
#
if [ -f "${adb_dnsdir}/${adb_dnsfile}" ]
then