aboutsummaryrefslogtreecommitdiff
path: root/net/adblock
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2022-10-22 09:23:23 +0200
committerDirk Brenken <dev@brenken.org>2022-10-22 09:23:23 +0200
commitca4c4d4fbcccf1b7b27ed10840b528482fd106fb (patch)
tree88ceb8d352a5c34a103b981bf78a3b6dd5484845 /net/adblock
parent647369bc456d844d614b3ec11b0e6cbb66eaf911 (diff)
adblock: update 4.1.5-3
* fixed search regression in DNS report * removed last shallalist pointers in the init help Signed-off-by: Dirk Brenken <dev@brenken.org>
Diffstat (limited to 'net/adblock')
-rw-r--r--net/adblock/Makefile2
-rwxr-xr-xnet/adblock/files/adblock.init2
-rwxr-xr-xnet/adblock/files/adblock.sh2
3 files changed, 3 insertions, 3 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index e6feeee82..603f5a2a2 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
PKG_VERSION:=4.1.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/adblock.init b/net/adblock/files/adblock.init
index 732c8a610..947e2f6ce 100755
--- a/net/adblock/files/adblock.init
+++ b/net/adblock/files/adblock.init
@@ -12,7 +12,7 @@ extra_command "suspend" "Suspend adblock processing"
extra_command "resume" "Resume adblock processing"
extra_command "query" "<domain> Query active blocklists and backups for a specific domain"
extra_command "report" "[[<cli>|<mail>|<gen>|<json>] [<top_count>] [<res_count>] [<search>]] Print DNS statistics with an optional search parameter"
-extra_command "list" "[<add>|<add_sha>|<add_utc>|<add_eng>|<add_stb>|<remove>|<remove_sha>|<remove_utc>|<remove_eng>|<remove_stb>] <source(s)> List/Edit available sources"
+extra_command "list" "[<add>|<add_utc>|<add_eng>|<add_stb>|<remove>|<remove_utc>|<remove_eng>|<remove_stb>] <source(s)> List/Edit available sources"
extra_command "timer" "[<add> <tasks> <hour> [<minute>] [<weekday>]]|[<remove> <line no.>] List/Edit cron update intervals"
adb_init="/etc/init.d/adblock"
diff --git a/net/adblock/files/adblock.sh b/net/adblock/files/adblock.sh
index f2a962378..2647df093 100755
--- a/net/adblock/files/adblock.sh
+++ b/net/adblock/files/adblock.sh
@@ -1470,7 +1470,7 @@ case "${adb_action}" in
[ "${adb_dns}" != "raw" ] && f_switch resume
;;
"report")
- f_report "${2}" "${3}" "${4}"
+ f_report "${2}" "${3}" "${4}" "${5}"
;;
"query")
f_query "${2}"