aboutsummaryrefslogtreecommitdiff
path: root/net/adblock
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2019-11-16 17:36:08 +0100
committerDirk Brenken <dev@brenken.org>2019-11-16 17:36:08 +0100
commitbc299d03f23a8c9d306868de34c191e4bb0ee19c (patch)
tree3d94b11faea1fa7fcab95b800faa52dea0e6dd2f /net/adblock
parente036312e6b38a4a3537e15f377b437f4485e22a5 (diff)
adblock: update 3.8.11
* some more init tweaks * update/cleanup readme Signed-off-by: Dirk Brenken <dev@brenken.org>
Diffstat (limited to 'net/adblock')
-rw-r--r--net/adblock/Makefile2
-rw-r--r--net/adblock/files/README.md65
-rwxr-xr-xnet/adblock/files/adblock.init12
-rwxr-xr-xnet/adblock/files/adblock.sh2
4 files changed, 41 insertions, 40 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index 51355a12b..b48f86b14 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
-PKG_VERSION:=3.8.10
+PKG_VERSION:=3.8.11
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/README.md b/net/adblock/files/README.md
index cb5b547de..ffe1c7869 100644
--- a/net/adblock/files/README.md
+++ b/net/adblock/files/README.md
@@ -129,40 +129,41 @@ A lot of people already use adblocker plugins within their desktop browsers, but
#### Further adblock config options
* Usually the pre-configured adblock setup works quite well and no manual overrides are needed
* The following options apply to the `global` config section:
- * `adb\_enabled` => Main switch to enable/disable adblock service (default: `0`, disabled)
- * `adb\_dns` => Select the DNS backend for your environment: `dnsmasq`, `unbound`, `named` or `kresd` (default: `dnsmasq`)
- * `adb\_dnsvariant` => Select the blocking variant: `nxdomain` (default, supported by all backends), `null (IPv4)` and `null (IPv4/IPv6)` both options are only supported by `dnsmasq`
- * `adb\_fetchutil` => Name of the used download utility: `uclient-fetch`, `wget`, `curl`, `aria2c`, `wget-nossl` or `busybox` (default: `uclient-fetch`)
- * `adb\_fetchparm` => Special config options for the download utility (default: not set)
- * `adb\_trigger` => Set the startup trigger to a certain interface, to `timed` or to `none` (default: `wan`)
+ * `adb_enabled` => Main switch to enable/disable adblock service (default: `0`, disabled)
+ * `adb_dns` => Select the DNS backend for your environment: `dnsmasq`, `unbound`, `named` or `kresd` (default: `dnsmasq`)
+ * `adb_dnsvariant` => Select the blocking variant: `nxdomain` (default, supported by all backends), `null (IPv4)` and `null (IPv4/IPv6)` both options are only supported by `dnsmasq`
+ * `adb_fetchutil` => Name of the used download utility: `uclient-fetch`, `wget`, `curl`, `aria2c`, `wget-nossl` or `busybox` (default: `uclient-fetch`)
+ * `adb_fetchparm` => Special config options for the download utility (default: not set)
+ * `adb_trigger` => Set the startup trigger to a certain interface, to `timed` or to `none` (default: `wan`)
* The following options apply to the `extra` config section:
- * `adb\_debug` => Enable/disable adblock debug output (default: `0`, disabled)
- * `adb\_nice` => Set the nice level of the adblock process and all sub-processes (int/default: `0`, standard priority)
- * `adb\_forcedns` => Force DNS requests to local resolver (bool/default: `0`, disabled)
- * `adb\_maxqueue` => Size of the download queue to handle downloads & list processing in parallel (int/default: `8`)
- * `adb\_dnsfilereset` => The final DNS blockfile will be purged after DNS backend loading to save storage space (bool/default: `false`, disabled)
- * `adb\_report` => Enable the background tcpdump gathering process to provide a detailed DNS Query Report (bool/default: `0`, disabled)
- * `adb\_repdir` => Target directory for DNS related report files generated by tcpdump (default: `/tmp`)
- * `adb\_backupdir` => Target directory for adblock backups (default: `/tmp`)
- * `adb\_mail` => Send notification emails in case of a processing errors or if the overall domain count is &le; 0 (bool/default: `0`, disabled)
- * `adb\_mreceiver` => Receiver address for adblock notification emails (default: not set)
+ * `adb_debug` => Enable/disable adblock debug output (default: `0`, disabled)
+ * `adb_nice` => Set the nice level of the adblock process and all sub-processes (int/default: `0`, standard priority)
+ * `adb_forcedns` => Force DNS requests to local resolver (bool/default: `0`, disabled)
+ * `adb_maxqueue` => Size of the download queue to handle downloads & list processing in parallel (int/default: `8`)
+ * `adb_dnsfilereset` => The final DNS blockfile will be purged after DNS backend loading to save storage space (bool/default: `false`, disabled)
+ * `adb_report` => Enable the background tcpdump gathering process to provide a detailed DNS Query Report (bool/default: `0`, disabled)
+ * `adb_repdir` => Target directory for DNS related report files generated by tcpdump (default: `/tmp`)
+ * `adb_backupdir` => Target directory for adblock backups (default: `/tmp`)
+ * `adb_mail` => Send notification emails in case of a processing errors or if the overall domain count is &le; 0 (bool/default: `0`, disabled)
+ * `adb_mreceiver` => Receiver address for adblock notification emails (default: not set)
* The following options could be added via "Additional Field" in LuCI and apply to the `extra` config section as well:
- * `adb\_dnsdir` => Target directory for the generated blocklist `adb_list.overall` (default: not set, use DNS backend default)
- * `adb\_blacklist` => Full path to the static blacklist file (default: `/etc/adblock/adblock.blacklist`)
- * `adb\_whitelist` => Full path to the static whitelist file (default: `/etc/adblock/adblock.whitelist`)
- * `adb\_triggerdelay` => Additional trigger delay in seconds before adblock processing begins (int/default: `2`)
- * `adb\_maxtld` => Disable the tld compression, if the number of blocked domains is greater than this value (int/default: `100000`)
- * `adb\_portlist` => Space separated list of fw ports which should be redirected locally (default: `53 853 5353`)
- * `adb\_dnsinotify` => Disable adblock triggered restarts and the 'DNS File Reset' for DNS backends with autoload features (bool/default: `false`, disabled)
- * `adb\_dnsflush` => Flush DNS cache after adblock processing, i.e. enable the old restart behavior (bool/default: `0`, disabled)
- * `adb\_repiface` => Reporting interface used by tcpdump, set to `any` for multiple interfaces (default: `br-lan`)
- * `adb\_replisten` => Space separated list of reporting port(s) used by tcpdump (default: `53`)
- * `adb\_repchunkcnt` => Report chunk count used by tcpdump (default: `5`)
- * `adb\_repchunksize` => Report chunk size used by tcpdump in MB (int/default: `1`)
- * `adb\_msender` => Sender address for adblock notification emails (default: `no-reply@adblock`)
- * `adb\_mtopic` => Topic for adblock notification emails (default: `adblock notification`)
- * `adb\_mprofile` => Email profile used in `msmtp` for adblock notification emails (default: `adb_notify`)
- * `adb\_mcnt` => Raise the minimum domain count email notification trigger (int/default: `0`)
+ * `adb_dnsdir` => Target directory for the generated blocklist `adb_list.overall` (default: not set, use DNS backend default)
+ * `adb_dnsinstance` => set the relevant adblock enabled dnsmasq instance (int/default: '0', first dnsmasq instance)
+ * `adb_blacklist` => Full path to the static blacklist file (default: `/etc/adblock/adblock.blacklist`)
+ * `adb_whitelist` => Full path to the static whitelist file (default: `/etc/adblock/adblock.whitelist`)
+ * `adb_triggerdelay` => Additional trigger delay in seconds before adblock processing begins (int/default: `2`)
+ * `adb_maxtld` => Disable the tld compression, if the number of blocked domains is greater than this value (int/default: `100000`)
+ * `adb_portlist` => Space separated list of fw ports which should be redirected locally (default: `53 853 5353`)
+ * `adb_dnsinotify` => Disable adblock triggered restarts and the 'DNS File Reset' for DNS backends with autoload features (bool/default: `false`, disabled)
+ * `adb_dnsflush` => Flush DNS cache after adblock processing, i.e. enable the old restart behavior (bool/default: `0`, disabled)
+ * `adb_repiface` => Reporting interface used by tcpdump, set to `any` for multiple interfaces (default: `br-lan`)
+ * `adb_replisten` => Space separated list of reporting port(s) used by tcpdump (default: `53`)
+ * `adb_repchunkcnt` => Report chunk count used by tcpdump (default: `5`)
+ * `adb_repchunksize` => Report chunk size used by tcpdump in MB (int/default: `1`)
+ * `adb_msender` => Sender address for adblock notification emails (default: `no-reply@adblock`)
+ * `adb_mtopic` => Topic for adblock notification emails (default: `adblock notification`)
+ * `adb_mprofile` => Email profile used in `msmtp` for adblock notification emails (default: `adb_notify`)
+ * `adb_mcnt` => Raise the minimum domain count email notification trigger (int/default: `0`)
#### Examples
**Change default DNS backend to `unbound`:**
diff --git a/net/adblock/files/adblock.init b/net/adblock/files/adblock.init
index d1367aed1..992869870 100755
--- a/net/adblock/files/adblock.init
+++ b/net/adblock/files/adblock.init
@@ -4,21 +4,21 @@
START=30
USE_PROCD=1
-EXTRA_COMMANDS="suspend resume query report status"
+EXTRA_COMMANDS="suspend resume query report"
EXTRA_HELP=" suspend Suspend adblock processing
resume Resume adblock processing
query <DOMAIN> Query active blocklists for specific domains
- report <SEARCH> Print dns query statistics with an optional search parameter
- status Print runtime information"
+ report <SEARCH> Print dns query statistics with an optional search parameter"
adb_init="/etc/init.d/adblock"
adb_script="/usr/bin/adblock.sh"
adb_pidfile="/var/run/adblock.pid"
-if [ -s "${adb_pidfile}" ] && \
- [ "${action}" != "help" ] && [ "${action}" != "status" ] && [ "${action}" != "boot" ] && [ "${action}" != "enabled" ]
+if [ -s "${adb_pidfile}" ] && { [ "${action}" = "start" ] || [ "${action}" = "stop" ] || \
+ [ "${action}" = "restart" ] || [ "${action}" = "reload" ] || [ "${action}" = "report" ] || \
+ [ "${action}" = "suspend" ] || [ "${action}" = "resume" ] || [ "${action}" = "query" ]; }
then
- exit 1
+ exit 0
fi
boot()
diff --git a/net/adblock/files/adblock.sh b/net/adblock/files/adblock.sh
index 551b47a5c..2ed382fd9 100755
--- a/net/adblock/files/adblock.sh
+++ b/net/adblock/files/adblock.sh
@@ -13,7 +13,7 @@
#
LC_ALL=C
PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_ver="3.8.10"
+adb_ver="3.8.11"
adb_basever=""
adb_enabled=0
adb_debug=0