aboutsummaryrefslogtreecommitdiff
path: root/net/adblock
diff options
context:
space:
mode:
authorThiago de Arruda Padilha <tpadilha84@gmail.com>2020-12-23 15:17:17 -0300
committerThiago de Arruda Padilha <tpadilha84@gmail.com>2020-12-23 16:59:32 -0300
commit864092e073a19c60f8210413c2182b63d6676811 (patch)
tree1b3e8ff8d26c52817aa3c45033f0033153811852 /net/adblock
parente8591daa9400cb64bda0c0178bf5ab05a0652688 (diff)
adblock: fix when PROCD_RELOAD_DELAY is set
Move the "PROCD_RELOAD_DELAY" line to after the "delay" variable is set. Signed-off-by: Thiago de Arruda Padilha <tpadilha84@gmail.com>
Diffstat (limited to 'net/adblock')
-rw-r--r--net/adblock/Makefile2
-rwxr-xr-xnet/adblock/files/adblock.init2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index f25ac5749..81be42b7e 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
PKG_VERSION:=4.0.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/adblock.init b/net/adblock/files/adblock.init
index c75ddee67..0aa219d44 100755
--- a/net/adblock/files/adblock.init
+++ b/net/adblock/files/adblock.init
@@ -246,10 +246,10 @@ service_triggers()
{
local trigger delay type
- PROCD_RELOAD_DELAY=$((delay*1000))
trigger="$(uci_get adblock global adb_trigger)"
delay="$(uci_get adblock global adb_triggerdelay "2")"
type="$(uci_get adblock global adb_starttype "start")"
+ PROCD_RELOAD_DELAY=$((delay*1000))
if [ -n "${trigger}" ]
then
procd_add_interface_trigger "interface.*.up" "${trigger}" "${adb_init}" "${type}"