aboutsummaryrefslogtreecommitdiff
path: root/net/adblock
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2020-04-07 21:48:09 +0200
committerDirk Brenken <dev@brenken.org>2020-04-07 21:48:09 +0200
commit40d35ea47e57fb35d159a19568f4a29f0057a8a5 (patch)
tree5f3826abff0549769d685f854a7d3c91154a033f /net/adblock
parentbdc23034ca061ad118f1031a5af7270a745498c5 (diff)
adblock: release 4.0.3
* add 'wally3k' and 'reg_vn' sources, change 'reg_pl' source * update readme * small fixes & cosmetics Signed-off-by: Dirk Brenken <dev@brenken.org>
Diffstat (limited to 'net/adblock')
-rw-r--r--net/adblock/Makefile2
-rw-r--r--net/adblock/files/README.md7
-rwxr-xr-xnet/adblock/files/adblock.sh26
-rw-r--r--net/adblock/files/adblock.sources20
4 files changed, 37 insertions, 18 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index a1f149b04..df3cb9389 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
-PKG_VERSION:=4.0.2
+PKG_VERSION:=4.0.3
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/README.md b/net/adblock/files/README.md
index aada8a0a1..a196e590d 100644
--- a/net/adblock/files/README.md
+++ b/net/adblock/files/README.md
@@ -31,9 +31,10 @@ A lot of people already use adblocker plugins within their desktop browsers, but
| reg_fi | | S | reg_finland | [Link](https://github.com/finnish-easylist-addition) |
| reg_id | | M | reg_indonesia | [Link](https://easylist.to) |
| reg_nl | | M | reg_netherlands | [Link](https://easylist.to) |
-| reg_pl | | S | reg_poland | [Link](http://adblocklist.org) |
+| reg_pl | | M | reg_poland | [Link](https://kadantiscam.netlify.com) |
| reg_ro | | M | reg_romania | [Link](https://easylist.to) |
| reg_ru | | M | reg_russia | [Link](https://easylist.to) |
+| reg_vn | | M | reg_vietnam | [Link](https://bigdargon.github.io/hostsVN) |
| shallalist | | L | general | [Link](https://www.shallalist.de) |
| shallalist_porn | | XXL | general+porn | [Link](https://www.shallalist.de) |
| smarttv | | S | smarttv | [Link](https://github.com/Perflyst/PiHoleBlocklist) |
@@ -43,6 +44,7 @@ A lot of people already use adblocker plugins within their desktop browsers, but
| sysctl | | M | general | [Link](http://sysctl.org/cameleon) |
| utcapitole | | L | general | [Link](https://dsi.ut-capitole.fr/blacklists/index_en.php) |
| utcapitole_porn | | XXL | general+porn | [Link](https://dsi.ut-capitole.fr/blacklists/index_en.php) |
+| wally3k | | S | compilation | [Link](https://firebog.net/about) |
| whocares | | M | general | [Link](https://someonewhocares.org) |
| winhelp | | S | general | [Link](http://winhelp2002.mvps.org) |
| winspy | | S | win_telemetry | [Link](https://github.com/crazy-max/WindowsSpyBlocker) |
@@ -91,6 +93,7 @@ A lot of people already use adblocker plugins within their desktop browsers, but
<b>Please note:</b> Devices with less than 128 MByte RAM are _not_ supported!
* A usual setup with an enabled DNS backend at minimum - dump AP modes without a working DNS backend are _not_ supported
* A download utility with SSL support: 'wget', 'uclient-fetch' with one of the 'libustream-*' ssl libraries, 'aria2c' or 'curl' is required
+* A certificate store such as 'ca-bundle' or 'ca-certificates', as adblock checks the validity of the SSL certificates of all download sites by default
* Optional E-Mail notification support: for E-Mail notifications you need to install the additional 'msmtp' package
* Optional DNS Query Report support: for DNS reporting you need to install the additional package 'tcpdump-mini' or 'tcpdump'
* Optional support for gnu awk as alternative to the busybox default, install the additional package 'gawk'
@@ -136,7 +139,7 @@ Available commands:
| adb_srcfile | -, /tmp/adb_sources.json | full path to the used adblock source file, which has a higher precedence than the archive file |
| adb_dns | -, auto-detected | 'dnsmasq', 'unbound', 'named', 'kresd' or 'raw' |
| adb_fetchutil | -, auto-detected | 'uclient-fetch', 'wget', 'curl' or 'aria2c' |
-| adb_fetchparm | -, auto-detected | config options for the selected download utility |
+| adb_fetchparm | -, auto-detected | config options for the selected download utility, e.g. to disable the certificate check |
| adb_trigger | -, not set | trigger network interface or 'not set' to use a time-based startup |
| adb_triggerdelay | 2 | additional trigger delay in seconds before adblock processing begins |
| adb_debug | 0, disabled | set to 1 to enable the debug output |
diff --git a/net/adblock/files/adblock.sh b/net/adblock/files/adblock.sh
index ef19f8545..14554232d 100755
--- a/net/adblock/files/adblock.sh
+++ b/net/adblock/files/adblock.sh
@@ -4,14 +4,14 @@
# This is free software, licensed under the GNU General Public License v3.
# set (s)hellcheck exceptions
-# shellcheck disable=1091 disable=2016 disable=2039 disable=2086 disable=2143 disable=2181 disable=2188
+# shellcheck disable=1091,2016,2039,2059,2086,2143,2181,2188
# set initial defaults
#
export LC_ALL=C
export PATH="/usr/sbin:/usr/bin:/sbin:/bin"
set -o pipefail
-adb_ver="4.0.2"
+adb_ver="4.0.3"
adb_enabled=0
adb_debug=0
adb_forcedns=0
@@ -310,7 +310,7 @@ f_dns()
if [ "${dns_up}" != "true" ]
then
f_dnsup 4
- if [ "${rc}" -ne 0 ]
+ if [ "${?}" -ne 0 ]
then
f_log "err" "dns backend '${adb_dns}' not running or executable"
fi
@@ -371,7 +371,7 @@ f_fetch()
fi
case "${adb_fetchutil}" in
"aria2c")
- adb_fetchparm="${adb_fetchparm:-"--timeout=20 --allow-overwrite=true --auto-file-renaming=false --check-certificate=true --dir=" " -o"}"
+ adb_fetchparm="${adb_fetchparm:-"--timeout=20 --allow-overwrite=true --auto-file-renaming=false --check-certificate=true --dir= -o"}"
;;
"curl")
adb_fetchparm="${adb_fetchparm:-"--connect-timeout 20 --silent --show-error --location -o"}"
@@ -600,13 +600,15 @@ f_extconf()
do
if [ -z "$(printf "%s" "${fwcfg}" | grep -Fo -m1 "adblock_dns_${port}")" ]
then
- uci_add firewall "redirect" "adblock_dns_${port}"
- uci_set firewall "adblock_dns_${port}" "name" "Adblock DNS, port ${port}"
- uci_set firewall "adblock_dns_${port}" "src" "lan"
- uci_set firewall "adblock_dns_${port}" "proto" "tcp udp"
- uci_set firewall "adblock_dns_${port}" "src_dport" "${port}"
- uci_set firewall "adblock_dns_${port}" "dest_port" "${port}"
- uci_set firewall "adblock_dns_${port}" "target" "DNAT"
+ uci -q batch <<-EOC
+ set firewall."adblock_dns_${port}"="redirect"
+ set firewall."adblock_dns_${port}".name="Adblock DNS, port ${port}"
+ set firewall."adblock_dns_${port}".src="lan"
+ set firewall."adblock_dns_${port}".proto="tcp udp"
+ set firewall."adblock_dns_${port}".src_dport="${port}"
+ set firewall."adblock_dns_${port}".dest_port="${port}"
+ set firewall."adblock_dns_${port}".target="DNAT"
+ EOC
fi
done
elif [ "${adb_enabled}" -eq 0 ] || [ "${adb_forcedns}" -eq 0 ]
@@ -699,7 +701,7 @@ f_list()
then
eval "${adb_dnsallow}" "${adb_tmpdir}/tmp.raw.${src_name}" > "${adb_tmpdir}/tmp.add.${src_name}"
out_rc="${?}"
- if [ "${out_rc}" -eq 0 ] && [ "${adb_jail}" = "1" ] && [ "${adb_dnssstop}" != "0" ]
+ if [ "${out_rc}" -eq 0 ] && [ "${adb_jail}" = "1" ] && [ "${adb_dnsstop}" != "0" ]
then
> "${adb_jaildir}/${adb_dnsjail}"
if [ -n "${adb_dnsheader}" ]
diff --git a/net/adblock/files/adblock.sources b/net/adblock/files/adblock.sources
index c01263873..425b739c2 100644
--- a/net/adblock/files/adblock.sources
+++ b/net/adblock/files/adblock.sources
@@ -161,11 +161,11 @@
"descurl": "https://easylist.to"
},
"reg_pl": {
- "url": "http://adblocklist.org/adblock-pxf-polish.txt",
- "rule": "BEGIN{FS=\"[|^]\"}/^\\|\\|([[:alnum:]_-]+\\.)+[[:alpha:]]+\\^(\\$third-party)?$/{print tolower($3)}",
+ "url": "https://raw.githubusercontent.com/PolishFiltersTeam/KADhosts/master/KADhosts_without_controversies.txt",
+ "rule": "/^0\\.0\\.0\\.0[[:space:]]+([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($2)}",
"size": "S",
"focus": "reg_poland",
- "descurl": "http://adblocklist.org"
+ "descurl": "https://kadantiscam.netlify.com"
},
"reg_ro": {
"url": "https://easylist-downloads.adblockplus.org/rolist+easylist.txt",
@@ -181,6 +181,13 @@
"focus": "reg_russia",
"descurl": "https://easylist.to"
},
+ "reg_vn": {
+ "url": "https://raw.githubusercontent.com/bigdargon/hostsVN/master/hosts",
+ "rule": "/^0\\.0\\.0\\.0[[:space:]]+([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($2)}",
+ "size": "S",
+ "focus": "reg_vietnam",
+ "descurl": "https://bigdargon.github.io/hostsVN"
+ },
"shallalist": {
"url": "https://www.shallalist.de/Downloads/shallalist.tar.gz",
"rule": "/^([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
@@ -256,6 +263,13 @@
"focus": "general+porn",
"descurl": "https://dsi.ut-capitole.fr/blacklists/index_en.php"
},
+ "wally3k": {
+ "url": "https://v.firebog.net/hosts/static/w3kbl.txt",
+ "rule": "/^([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
+ "size": "S",
+ "focus": "compilation",
+ "descurl": "https://firebog.net/about"
+ },
"whocares": {
"url": "https://someonewhocares.org/hosts/hosts",
"rule": "/^127\\.0\\.0\\.1[[:space:]]+([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($2)}",