aboutsummaryrefslogtreecommitdiff
path: root/net/adblock
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2016-09-29 18:07:45 +0200
committerDirk Brenken <dev@brenken.org>2016-09-29 18:07:45 +0200
commit23b14e7b4cc08f822744478651af993e67777b80 (patch)
tree75690020fff443eec38a3dbab7538df8774a6ad0 /net/adblock
parent564dc2294a3774931bdedc0d86af487bbf3e47a1 (diff)
adblock: update 1.4.10
- add 'enabled' check to iface hotplug event handler - decrease startup priority from 99 to 90 - fix tab indentation in config Signed-off-by: Dirk Brenken <dev@brenken.org>
Diffstat (limited to 'net/adblock')
5 files changed, 9 insertions, 8 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index d79bf5199..5d56aab23 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
-PKG_VERSION:=1.4.9
+PKG_VERSION:=1.4.10
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/adblock-update.sh b/net/adblock/files/adblock-update.sh
index c1e467d7c..4092d84fb 100755
--- a/net/adblock/files/adblock-update.sh
+++ b/net/adblock/files/adblock-update.sh
@@ -10,7 +10,7 @@
#
adb_pid="${$}"
adb_pidfile="/var/run/adblock.pid"
-adb_scriptver="1.4.9"
+adb_scriptver="1.4.10"
adb_mincfgver="2.5"
adb_scriptdir="${0%/*}"
if [ -r "${adb_pidfile}" ]
diff --git a/net/adblock/files/adblock.conf b/net/adblock/files/adblock.conf
index da58c2e83..cc86b503b 100644
--- a/net/adblock/files/adblock.conf
+++ b/net/adblock/files/adblock.conf
@@ -91,10 +91,10 @@ config source 'ruadlist'
option adb_src_desc 'focus on russian ads plus generic easylist additions, weekly updates, approx. 2.000 entries'
config source 'securemecca'
- option enabled '0'
- option adb_src 'http://securemecca.com/Downloads/hosts.txt'
- option adb_src_rset '\$0 ~/^127\.0\.0\.1[ \t]+([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\$2)}'
- option adb_src_desc 'broad blocklist, infrequent updates, approx. 25.000 entries'
+ option enabled '0'
+ option adb_src 'http://securemecca.com/Downloads/hosts.txt'
+ option adb_src_rset '\$0 ~/^127\.0\.0\.1[ \t]+([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\$2)}'
+ option adb_src_desc 'broad blocklist, infrequent updates, approx. 25.000 entries'
config source 'shalla'
option enabled '0'
diff --git a/net/adblock/files/adblock.hotplug b/net/adblock/files/adblock.hotplug
index 33377b5e6..ee48bb05c 100644
--- a/net/adblock/files/adblock.hotplug
+++ b/net/adblock/files/adblock.hotplug
@@ -4,8 +4,9 @@
adb_pid="${$}"
adb_helper="/usr/bin/adblock-helper.sh"
adb_pidfile="/var/run/adblock.pid"
+adb_enabled="$(/etc/init.d/adblock enabled; echo $?)"
-if [ -f "${adb_pidfile}" ] || [ "${ACTION}" != "ifup" ]
+if [ "${adb_enabled}" = "1" ] || [ -f "${adb_pidfile}" ] || [ "${ACTION}" != "ifup" ]
then
exit 0
fi
diff --git a/net/adblock/files/adblock.init b/net/adblock/files/adblock.init
index f7b707a21..e683dfa75 100755
--- a/net/adblock/files/adblock.init
+++ b/net/adblock/files/adblock.init
@@ -1,7 +1,7 @@
#!/bin/sh /etc/rc.common
#
-START=99
+START=90
EXTRA_COMMANDS="toggle stats cfgup query"
EXTRA_HELP=" toggle Toggle adblock 'on' or 'off'
stats Update adblock statistics