aboutsummaryrefslogtreecommitdiff
path: root/net/acme-common
diff options
context:
space:
mode:
authorGlen Huang <i@glenhuang.com>2022-10-22 21:42:10 +0800
committerGlen Huang <i@glenhuang.com>2022-10-22 21:42:10 +0800
commitcbc06f45b9c02263f901ef7c4214d0e489cec822 (patch)
tree4129155530bf3af90ff589ecf1fe455f41aea200 /net/acme-common
parent465f56adc210be28ae0c6e34c54d1c55c09db6fc (diff)
acme: make package create dir /etc/ssl/acme
Since the dir is a standardized one, it should not be created dynamically Signed-off-by: Glen Huang <i@glenhuang.com>
Diffstat (limited to 'net/acme-common')
-rw-r--r--net/acme-common/Makefile1
-rw-r--r--net/acme-common/files/acme.sh1
2 files changed, 1 insertions, 1 deletions
diff --git a/net/acme-common/Makefile b/net/acme-common/Makefile
index b4ff360a8..997c31e31 100644
--- a/net/acme-common/Makefile
+++ b/net/acme-common/Makefile
@@ -34,6 +34,7 @@ define Package/acme-common/conffiles
endef
define Package/acme-common/install
+ $(INSTALL_DIR) $(1)/etc/ssl/acme
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/acme.config $(1)/etc/config/acme
$(INSTALL_DIR) $(1)/usr/bin
diff --git a/net/acme-common/files/acme.sh b/net/acme-common/files/acme.sh
index 8972c4f0e..1ed32af7e 100644
--- a/net/acme-common/files/acme.sh
+++ b/net/acme-common/files/acme.sh
@@ -131,7 +131,6 @@ get)
config_load acme
config_foreach load_globals acme
- mkdir -p /etc/ssl/acme
trap cleanup EXIT
config_foreach get_cert cert
;;