aboutsummaryrefslogtreecommitdiff
path: root/net/acme-common
diff options
context:
space:
mode:
authorGlen Huang <me@glenhuang.com>2023-04-26 19:46:46 +0800
committerToke Høiland-Jørgensen <toke@toke.dk>2023-04-26 22:42:26 +0200
commit8589f298a130cb28cf0c769b50c1a4c116a3d70b (patch)
tree1bc66510d1752e85d85b2342aac4ef3b210d495a /net/acme-common
parent1bfd2f7adeaafb317345af41f472564d9ae28a79 (diff)
acme: remove redundant postinst
opkg runs uci-defaults if a package installs one, in acme-common's case that's identical to postinst. prerm shouldn't be run a image builder, so it's unnecessary to check IPKG_INSTROOT Signed-off-by: Glen Huang <me@glenhuang.com>
Diffstat (limited to 'net/acme-common')
-rw-r--r--net/acme-common/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/net/acme-common/Makefile b/net/acme-common/Makefile
index 841146826..ac92fc564 100644
--- a/net/acme-common/Makefile
+++ b/net/acme-common/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=acme-common
-PKG_VERSION:=1.0.2
+PKG_VERSION:=1.0.3
PKG_MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
PKG_LICENSE:=GPL-3.0-only
@@ -48,19 +48,9 @@ define Package/acme-common/install
$(INSTALL_DIR) $(1)/etc/hotplug.d/acme
endef
-define Package/acme-common/postinst
-#!/bin/sh
-if [ -z "$$IPKG_INSTROOT" ]; then
- grep -q '/etc/init.d/acme' /etc/crontabs/root 2>/dev/null && exit 0
- echo "0 0 * * * /etc/init.d/acme start" >> /etc/crontabs/root
-fi
-endef
-
define Package/acme-common/prerm
#!/bin/sh
-if [ -z "$$IPKG_INSTROOT" ]; then
- sed -i '\|/etc/init.d/acme|d' /etc/crontabs/root
-fi
+sed -i '\|/etc/init.d/acme|d' /etc/crontabs/root
endef
define Build/Configure