aboutsummaryrefslogtreecommitdiff
path: root/net/acme-common
diff options
context:
space:
mode:
authorGlen Huang <me@glenhuang.com>2023-05-17 17:27:38 +0800
committerGlen Huang <me@glenhuang.com>2023-05-17 17:27:38 +0800
commit38eeca5df92c6f8fedd153e7383904eb5b893beb (patch)
treea12414d6d3d9344ee3d1f218abe9793c26f1babe /net/acme-common
parentc2a3a9566a5fab97ee8d3a7f782d0290001a7498 (diff)
acme-common: no exporting webroot
ACME clients shouldn't deal with deprecated values. They should be processed by acme-common. Reformatting is done by shfmt. Signed-off-by: Glen Huang <me@glenhuang.com>
Diffstat (limited to 'net/acme-common')
-rw-r--r--net/acme-common/Makefile2
-rw-r--r--net/acme-common/files/acme.init2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/acme-common/Makefile b/net/acme-common/Makefile
index ac92fc564..324b742b6 100644
--- a/net/acme-common/Makefile
+++ b/net/acme-common/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=acme-common
-PKG_VERSION:=1.0.3
+PKG_VERSION:=1.0.4
PKG_MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
PKG_LICENSE:=GPL-3.0-only
diff --git a/net/acme-common/files/acme.init b/net/acme-common/files/acme.init
index a97856496..a365ecd3e 100644
--- a/net/acme-common/files/acme.init
+++ b/net/acme-common/files/acme.init
@@ -53,9 +53,9 @@ load_options() {
export dns_wait
config_get webroot "$section" webroot
- export webroot
if [ "$webroot" ]; then
log warn "Option \"webroot\" is deprecated, please remove it and change your web server's config so it serves ACME challenge requests from $CHALLENGE_DIR."
+ CHALLENGE_DIR=$webroot
fi
}