aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-04 14:39:22 -0700
committerRosen Penev <rosenp@gmail.com>2020-08-04 19:05:41 -0700
commitf2dae99c4169d00f83cc89cd66a77b5659652ff8 (patch)
treee209971b2e9d85d61c674d34bd39ca3d40421167 /multimedia
parent7f620401afb185abac26e5e186150f5b53ea6ed0 (diff)
motion: fix old libmicrohttpd usage
Doesn't seem to be needed for this package but it does fix several warnings. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/motion/Makefile2
-rw-r--r--multimedia/motion/patches/020-libmicrohttpd.patch47
2 files changed, 48 insertions, 1 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index 283adc721..0caecf35a 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=motion
PKG_VERSION:=4.3.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-release-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/Motion-Project/motion/tar.gz/release-$(PKG_VERSION)?
diff --git a/multimedia/motion/patches/020-libmicrohttpd.patch b/multimedia/motion/patches/020-libmicrohttpd.patch
new file mode 100644
index 000000000..6a0fadfae
--- /dev/null
+++ b/multimedia/motion/patches/020-libmicrohttpd.patch
@@ -0,0 +1,47 @@
+--- a/src/webu.c
++++ b/src/webu.c
+@@ -1203,7 +1203,7 @@ static void webu_answer_strm_type(struct webui_ctx *webui) {
+
+ }
+
+-static int webu_answer_ctrl(void *cls
++static enum MHD_Result webu_answer_ctrl(void *cls
+ , struct MHD_Connection *connection
+ , const char *url
+ , const char *method
+@@ -1213,7 +1213,7 @@ static int webu_answer_ctrl(void *cls
+ , void **ptr) {
+
+ /* This function "answers" the request for a webcontrol.*/
+- int retcd;
++ enum MHD_Result retcd;
+ struct webui_ctx *webui = *ptr;
+
+ /* Eliminate compiler warnings */
+@@ -1275,7 +1275,7 @@ static int webu_answer_ctrl(void *cls
+
+ }
+
+-static int webu_answer_strm(void *cls
++static enum MHD_Result webu_answer_strm(void *cls
+ , struct MHD_Connection *connection
+ , const char *url
+ , const char *method
+@@ -1285,7 +1285,7 @@ static int webu_answer_strm(void *cls
+ , void **ptr) {
+
+ /* Answer the request for all the streams*/
+- int retcd;
++ enum MHD_Result retcd;
+ struct webui_ctx *webui = *ptr;
+
+ /* Eliminate compiler warnings */
+@@ -1484,7 +1484,7 @@ static void webu_mhd_features_basic(struct mhdstart_ctx *mhdst){
+ #if MHD_VERSION < 0x00094400
+ (void)mhdst;
+ #else
+- int retcd;
++ enum MHD_Result retcd;
+ retcd = MHD_is_feature_supported (MHD_FEATURE_BASIC_AUTH);
+ if (retcd == MHD_YES){
+ MOTION_LOG(DBG, TYPE_STREAM, NO_ERRNO ,_("Basic authentication: available"));