aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-10 14:45:40 -0700
committerRosen Penev <rosenp@gmail.com>2020-08-10 15:52:59 -0700
commite3c67016f83bbc88a7dfda733a80def3e2c6c797 (patch)
tree77e4564bc70d7cd9a33a4fc65c8470f85335fdb6 /multimedia
parent8fa65a875498fa1e4c0a79dde3ac4059b7d26e8c (diff)
tvheadend: fix compilation with GCC 10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/tvheadend/Makefile2
-rw-r--r--multimedia/tvheadend/patches/030-gcc10.patch24
2 files changed, 25 insertions, 1 deletions
diff --git a/multimedia/tvheadend/Makefile b/multimedia/tvheadend/Makefile
index 9108b9296..e75e90cf0 100644
--- a/multimedia/tvheadend/Makefile
+++ b/multimedia/tvheadend/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tvheadend
PKG_VERSION:=4.0.10
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/tvheadend/tvheadend/tar.gz/v$(PKG_VERSION)?
diff --git a/multimedia/tvheadend/patches/030-gcc10.patch b/multimedia/tvheadend/patches/030-gcc10.patch
new file mode 100644
index 000000000..8358f99b8
--- /dev/null
+++ b/multimedia/tvheadend/patches/030-gcc10.patch
@@ -0,0 +1,24 @@
+--- a/src/input.h
++++ b/src/input.h
+@@ -120,8 +120,8 @@ void tvh_hardware_delete ( tvh_hardware_t *th );
+ extern const idclass_t tvh_input_class;
+ extern const idclass_t tvh_input_instance_class;
+
+-tvh_input_list_t tvh_inputs;
+-tvh_hardware_list_t tvh_hardware;
++extern tvh_input_list_t tvh_inputs;
++extern tvh_hardware_list_t tvh_hardware;
+
+ #define TVH_INPUT_FOREACH(x) LIST_FOREACH(x, &tvh_inputs, ti_link)
+ #define TVH_HARDWARE_FOREACH(x) LIST_FOREACH(x, &tvh_hardware, th_link)
+--- a/src/input/mpegts.h
++++ b/src/input/mpegts.h
+@@ -1017,7 +1017,7 @@ typedef struct mpegts_listener
+ void (*ml_mux_delete) (mpegts_mux_t *mm, void *p);
+ } mpegts_listener_t;
+
+-LIST_HEAD(,mpegts_listener) mpegts_listeners;
++static LIST_HEAD(,mpegts_listener) mpegts_listeners;
+
+ #define mpegts_add_listener(ml)\
+ LIST_INSERT_HEAD(&mpegts_listeners, ml, ml_link)