aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-12-28 15:38:06 +0200
committerGitHub <noreply@github.com>2018-12-28 15:38:06 +0200
commitcee1e13c9d20385e675b751e6e83a2d3ae623ccb (patch)
tree76edb7be67783927633907ddb85d16e8faf3d48c /multimedia
parent6bd150a479f3bd0c7749813bc10196000c9680eb (diff)
parent7a4ed7b6596ebfe156b7ddb29b46041b1778724c (diff)
Merge pull request #7654 from BKPepe/youtube-dl
youtube-dl: update to version 2018.12.09
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/youtube-dl/Makefile16
-rw-r--r--multimedia/youtube-dl/patches/dont-use-pandoc.patch21
2 files changed, 29 insertions, 8 deletions
diff --git a/multimedia/youtube-dl/Makefile b/multimedia/youtube-dl/Makefile
index 8aa1160fc..30a9a3aaa 100644
--- a/multimedia/youtube-dl/Makefile
+++ b/multimedia/youtube-dl/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=youtube-dl
-PKG_VERSION:=2018.06.04
+PKG_VERSION:=2018.12.09
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://yt-dl.org/downloads/$(PKG_VERSION)/
-PKG_HASH:=436ef69e59a1acf8091f5c294a563d6859ce6ec42543ea3abb501e2c09131301
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_SOURCE_URL:=https://codeload.github.com/rg3/youtube-dl/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=f277dee39adcf1fa19a14846eebc1e2c3749dd245e11d51783fa5ea366f34bff
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_LICENSE:=Unlicense
PKG_LICENSE_FILES:=LICENSE
@@ -33,20 +33,20 @@ define Package/youtube-dl
endef
define Package/youtube-dl/description
- youtube-dl is a small command-line program to download videos
- from YouTube.com and a few more sites.
+ youtube-dl is a small command-line program to download videos
+ from YouTube.com and a few more sites.
It requires the Python interpreter.
endef
define Package/youtube-dl/install
$(INSTALL_DIR) $(1)/usr/bin
-
+
python -m compileall $(PKG_BUILD_DIR)/youtube_dl/
cd $(PKG_BUILD_DIR) && zip --quiet youtube-dl-c.zip youtube_dl/*.pyc youtube_dl/*/*.pyc
cd $(PKG_BUILD_DIR) && zip --quiet --junk-paths youtube-dl-c.zip youtube_dl/__main__.pyc
echo '#!/usr/bin/env python' > $(PKG_BUILD_DIR)/youtube-dl-c
cat $(PKG_BUILD_DIR)/youtube-dl-c.zip >> $(PKG_BUILD_DIR)/youtube-dl-c
-
+
$(INSTALL_BIN) -T $(PKG_BUILD_DIR)/youtube-dl-c $(1)/usr/bin/youtube-dl
endef
diff --git a/multimedia/youtube-dl/patches/dont-use-pandoc.patch b/multimedia/youtube-dl/patches/dont-use-pandoc.patch
new file mode 100644
index 000000000..51b3dd588
--- /dev/null
+++ b/multimedia/youtube-dl/patches/dont-use-pandoc.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index 4a62f44..fee93e8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -85,12 +85,12 @@ supportedsites:
+ $(PYTHON) devscripts/make_supportedsites.py docs/supportedsites.md
+
+ README.txt: README.md
+- pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
++# pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
+
+ youtube-dl.1: README.md
+- $(PYTHON) devscripts/prepare_manpage.py youtube-dl.1.temp.md
+- pandoc -s -f $(MARKDOWN) -t man youtube-dl.1.temp.md -o youtube-dl.1
+- rm -f youtube-dl.1.temp.md
++# $(PYTHON) devscripts/prepare_manpage.py youtube-dl.1.temp.md
++# pandoc -s -f $(MARKDOWN) -t man youtube-dl.1.temp.md -o youtube-dl.1
++# rm -f youtube-dl.1.temp.md
+
+ youtube-dl.bash-completion: youtube_dl/*.py youtube_dl/*/*.py devscripts/bash-completion.in
+ $(PYTHON) devscripts/bash-completion.py