aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-01-01 21:46:47 -0800
committerRosen Penev <rosenp@gmail.com>2019-01-01 21:46:47 -0800
commitc59e53619e0b0b3c19651023456e500e6906dbd2 (patch)
treea7a0d96469b14f6cdced3f3df4bb6a524348e137 /multimedia
parent5bae7c73a767ac67428142066d74b3e056a1ff16 (diff)
tvheadend: Fix compilation without deprecated OpenSSL 1.0.2 APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/tvheadend/Makefile2
-rw-r--r--multimedia/tvheadend/patches/010-openssl-deprecated.patch9
2 files changed, 9 insertions, 2 deletions
diff --git a/multimedia/tvheadend/Makefile b/multimedia/tvheadend/Makefile
index 634ed7eac..4a41a9f38 100644
--- a/multimedia/tvheadend/Makefile
+++ b/multimedia/tvheadend/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tvheadend
PKG_VERSION:=4.0.10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/tvheadend/tvheadend/tar.gz/v$(PKG_VERSION)?
diff --git a/multimedia/tvheadend/patches/010-openssl-deprecated.patch b/multimedia/tvheadend/patches/010-openssl-deprecated.patch
index 93b6072d3..5416ef7fa 100644
--- a/multimedia/tvheadend/patches/010-openssl-deprecated.patch
+++ b/multimedia/tvheadend/patches/010-openssl-deprecated.patch
@@ -25,7 +25,14 @@
RAND_cleanup();
CRYPTO_cleanup_all_ex_data();
EVP_cleanup();
-@@ -1174,6 +1179,7 @@ main(int argc, char **argv)
+@@ -1168,12 +1173,13 @@ main(int argc, char **argv)
+ #ifndef OPENSSL_NO_COMP
+ COMP_zlib_cleanup();
+ #endif
+- ERR_remove_state(0);
++ ERR_remove_thread_state(NULL);
+ ERR_free_strings();
+ #ifndef OPENSSL_NO_COMP
sk_SSL_COMP_free(SSL_COMP_get_compression_methods());
#endif
/* end of OpenSSL cleanup code */