aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2014-07-16 22:00:28 -0400
committerW. Michael Petullo <mike@flyn.org>2014-07-31 10:44:40 -0400
commita4ffe9bf9fbb435ab77b9ca8d0cc48074f744380 (patch)
tree59c7c42ed8cc0dbdc54f7233ea7ace07979d03f1 /multimedia
parent297bf69c4a2a52bcbfba0e07bb5291e09d4d6550 (diff)
Add gstreamer1 package
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer1/Makefile190
-rw-r--r--multimedia/gstreamer1/patches/001-no_docs.patch37
-rw-r--r--multimedia/gstreamer1/patches/002-no_tests.patch39
-rw-r--r--multimedia/gstreamer1/patches/003-no_translations.patch48
4 files changed, 314 insertions, 0 deletions
diff --git a/multimedia/gstreamer1/Makefile b/multimedia/gstreamer1/Makefile
new file mode 100644
index 000000000..3a37c1fba
--- /dev/null
+++ b/multimedia/gstreamer1/Makefile
@@ -0,0 +1,190 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gstreamer1
+PKG_VERSION:=1.2.3
+PKG_RELEASE:=1
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
+PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
+PKG_MD5SUM:=8155b9c7574ccaa361cc504e8e0e72dc
+
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=autogen.sh aclocal.m4
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/gstreamer1/Default
+ CATEGORY:=Multimedia
+ SECTION:=multimedia
+ TITLE:=GStreamer
+ URL:=http://gstreamer.freedesktop.org/
+endef
+
+define Package/gstreamer1/description/Default
+ GStreamer open source multimedia framework
+endef
+
+
+define Package/gstreamer1
+$(call Package/gstreamer1/Default)
+ TITLE+= framework
+ DEPENDS+= +libgstreamer1 \
+ +libgst1check \
+ +libgst1controller \
+ +libgst1net
+endef
+
+define Package/gstreamer1/description
+$(call Package/gstreamer1/description/Default)
+ .
+ This meta package contains only dependencies on the other GStreamer
+ componenents.
+endef
+
+
+define Package/gstreamer1-utils
+$(call Package/gstreamer1/Default)
+ TITLE+= utilities
+ DEPENDS+= +libgstreamer1
+endef
+
+define Package/gstreamer1-utils/description
+$(call Package/gstreamer1/description/Default)
+ .
+ This package contains the GStreamer utilities.
+endef
+
+
+define Package/libgstreamer1
+$(call Package/gstreamer1/Default)
+ TITLE+= library (core)
+ DEPENDS+= +glib2 +libpthread +libxml2
+endef
+
+define Package/libgstreamer1/description
+$(call Package/gstreamer1/description/Default)
+ .
+ This package contains the GStreamer core library.
+endef
+
+
+GST_VERSION:=1.0
+
+CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-examples \
+ --disable-tests \
+ --disable-valgrind \
+ --without-libiconv-prefix \
+ --without-libintl-prefix \
+ --without-x \
+
+EXTRA_LDFLAGS+= \
+ -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+ -L$(ICONV_PREFIX)/lib -L$(INTL_PREFIX)/lib
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/gstreamer-$(GST_VERSION)
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
+ ./usr/include/gstreamer-$(GST_VERSION)/* \
+ $(1)/usr/include/gstreamer-$(GST_VERSION)/ \
+ )
+ $(INSTALL_DIR) $(1)/usr/lib
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
+ ./usr/lib/libgst*-$(GST_VERSION).{a,la,so*} \
+ $(1)/usr/lib/ \
+ )
+ $(INSTALL_DIR) $(1)/usr/lib/gstreamer-$(GST_VERSION)
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
+ ./usr/lib/gstreamer-$(GST_VERSION)/libgst*.{la,so} \
+ $(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
+ )
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
+ ./usr/lib/pkgconfig/gstreamer*-$(GST_VERSION).pc \
+ $(1)/usr/lib/pkgconfig/ \
+ )
+ $(INSTALL_DIR) $(2)/share/aclocal
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
+ ./usr/share/aclocal/* \
+ $(2)/share/aclocal/ \
+ )
+endef
+
+define Package/gstreamer1/install
+ /bin/true
+endef
+
+define Package/gstreamer1-utils/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
+ ./usr/bin/gst-launch* \
+ ./usr/bin/gst-inspect* \
+ ./usr/bin/gst-typefind* \
+ $(1)/usr/bin/ \
+ )
+endef
+
+define Package/libgstreamer1/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
+ ./usr/lib/libgstbase-$(GST_VERSION).so.* \
+ ./usr/lib/libgstreamer-$(GST_VERSION).so.* \
+ $(1)/usr/lib/ \
+ )
+ $(INSTALL_DIR) $(1)/usr/lib/gstreamer-$(GST_VERSION)
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
+ ./usr/lib/gstreamer-$(GST_VERSION)/libgst*.so \
+ $(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
+ )
+endef
+
+
+# 1: short name
+# 2: description
+# 3: dependencies on other gstreamer libraries (short name)
+# 4: dependencies on other packages
+define GstBuildLibrary
+
+ define Package/libgst1$(1)
+ $(call Package/gstreamer1/Default)
+ TITLE+= $(2) library (core)
+ DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $(4)
+ endef
+
+ define Package/libgst1$(1)/description
+ $(call Package/gstreamer1/description/Default)
+ .
+ This package contains the GStreamer $(2) library.
+ endef
+
+ define Package/libgst1$(1)/install
+ $(INSTALL_DIR) $$(1)/usr/lib
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
+ ./usr/lib/libgst$(1)-$(GST_VERSION).so.* \
+ $$(1)/usr/lib/ \
+ )
+ endef
+
+ $$(eval $$(call BuildPackage,libgst1$(1)))
+endef
+
+$(eval $(call GstBuildLibrary,check,check unit testing))
+$(eval $(call GstBuildLibrary,controller,dynamic parameter control))
+$(eval $(call GstBuildLibrary,net,network classes))
+
+$(eval $(call BuildPackage,libgstreamer1))
+$(eval $(call BuildPackage,gstreamer1))
+$(eval $(call BuildPackage,gstreamer1-utils))
diff --git a/multimedia/gstreamer1/patches/001-no_docs.patch b/multimedia/gstreamer1/patches/001-no_docs.patch
new file mode 100644
index 000000000..744f1c6ac
--- /dev/null
+++ b/multimedia/gstreamer1/patches/001-no_docs.patch
@@ -0,0 +1,37 @@
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
+--- gstreamer-1.0.7-vanilla/Makefile.am 2013-06-01 18:47:44.498057069 -0500
++++ gstreamer-1.0.7/Makefile.am 2013-06-01 19:01:41.634143861 -0500
+@@ -8,7 +8,6 @@
+
+ SUBDIRS = pkgconfig \
+ gst libs plugins tests \
+- docs \
+ po \
+ m4 \
+ common
+@@ -20,7 +19,6 @@
+ # These are all the possible subdirs
+ DIST_SUBDIRS = pkgconfig \
+ gst libs plugins tools tests \
+- docs \
+ po \
+ m4 \
+ common
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
+--- gstreamer-1.0.7-vanilla/Makefile.in 2013-06-01 18:47:44.533056863 -0500
++++ gstreamer-1.0.7/Makefile.in 2013-06-01 19:02:04.529246907 -0500
+@@ -508,13 +508,12 @@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
+ aclocaldir = $(datadir)/aclocal
+ aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
+-SUBDIRS = pkgconfig gst libs plugins tests docs po m4 common \
++SUBDIRS = pkgconfig gst libs plugins tests po m4 common \
+ $(am__append_1)
+
+ # These are all the possible subdirs
+ DIST_SUBDIRS = pkgconfig \
+ gst libs plugins tools tests \
+- docs \
+ po \
+ m4 \
+ common
diff --git a/multimedia/gstreamer1/patches/002-no_tests.patch b/multimedia/gstreamer1/patches/002-no_tests.patch
new file mode 100644
index 000000000..e002becfb
--- /dev/null
+++ b/multimedia/gstreamer1/patches/002-no_tests.patch
@@ -0,0 +1,39 @@
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
+--- gstreamer-1.0.7-vanilla/Makefile.am 2013-06-01 19:22:31.546496381 -0500
++++ gstreamer-1.0.7/Makefile.am 2013-06-01 19:20:38.141070908 -0500
+@@ -7,7 +7,7 @@
+ aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
+
+ SUBDIRS = pkgconfig \
+- gst libs plugins tests \
++ gst libs plugins \
+ po \
+ m4 \
+ common
+@@ -18,7 +18,7 @@
+
+ # These are all the possible subdirs
+ DIST_SUBDIRS = pkgconfig \
+- gst libs plugins tools tests \
++ gst libs plugins tools \
+ po \
+ m4 \
+ common
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
+--- gstreamer-1.0.7-vanilla/Makefile.in 2013-06-01 19:22:31.547496342 -0500
++++ gstreamer-1.0.7/Makefile.in 2013-06-01 19:20:48.948632307 -0500
+@@ -508,12 +508,12 @@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
+ aclocaldir = $(datadir)/aclocal
+ aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
+-SUBDIRS = pkgconfig gst libs plugins tests po m4 common \
++SUBDIRS = pkgconfig gst libs plugins po m4 common \
+ $(am__append_1)
+
+ # These are all the possible subdirs
+ DIST_SUBDIRS = pkgconfig \
+- gst libs plugins tools tests \
++ gst libs plugins tools \
+ po \
+ m4 \
+ common
diff --git a/multimedia/gstreamer1/patches/003-no_translations.patch b/multimedia/gstreamer1/patches/003-no_translations.patch
new file mode 100644
index 000000000..e2561993f
--- /dev/null
+++ b/multimedia/gstreamer1/patches/003-no_translations.patch
@@ -0,0 +1,48 @@
+diff -u --recursive gstreamer-1.0.7-vanilla/configure.ac gstreamer-1.0.7/configure.ac
+--- gstreamer-1.0.7-vanilla/configure.ac 2013-06-01 18:47:44.506057110 -0500
++++ gstreamer-1.0.7/configure.ac 2013-06-01 19:24:05.035756124 -0500
+@@ -769,7 +769,6 @@
+ libs/gst/net/Makefile
+ plugins/Makefile
+ plugins/elements/Makefile
+-po/Makefile.in
+ tests/Makefile
+ tests/benchmarks/Makefile
+ tests/check/Makefile
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
+--- gstreamer-1.0.7-vanilla/Makefile.am 2013-06-01 19:23:08.361020919 -0500
++++ gstreamer-1.0.7/Makefile.am 2013-06-01 19:24:15.036357308 -0500
+@@ -8,7 +8,6 @@
+
+ SUBDIRS = pkgconfig \
+ gst libs plugins \
+- po \
+ m4 \
+ common
+
+@@ -19,7 +18,6 @@
+ # These are all the possible subdirs
+ DIST_SUBDIRS = pkgconfig \
+ gst libs plugins tools \
+- po \
+ m4 \
+ common
+
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
+--- gstreamer-1.0.7-vanilla/Makefile.in 2013-06-01 19:23:08.362020867 -0500
++++ gstreamer-1.0.7/Makefile.in 2013-06-01 19:24:27.907844191 -0500
+@@ -508,13 +508,12 @@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
+ aclocaldir = $(datadir)/aclocal
+ aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
+-SUBDIRS = pkgconfig gst libs plugins po m4 common \
++SUBDIRS = pkgconfig gst libs plugins m4 common \
+ $(am__append_1)
+
+ # These are all the possible subdirs
+ DIST_SUBDIRS = pkgconfig \
+ gst libs plugins tools \
+- po \
+ m4 \
+ common
+