aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorIan Leonard <antonlacon@gmail.com>2014-12-14 16:17:06 -0800
committerIan Leonard <antonlacon@gmail.com>2014-12-14 16:19:10 -0800
commit665cd72e82939f3c29f5d0ea47dedb6b2fd4ca66 (patch)
treea6c9d60ceb5315665e16f3f168d7bd009c7797cb /multimedia
parent65d8897100012b948e29b9d3ee71b468df6afac4 (diff)
ffmpeg: Update to 2.4.4
Drop fminf patch; fminf emulation is no longer included upstream. Signed-off-by: Ian Leonard <antonlacon@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg/Makefile4
-rw-r--r--multimedia/ffmpeg/patches/010-remove_unused_fminf_definition.patch18
2 files changed, 2 insertions, 20 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 4316aae49..f3053748c 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ffmpeg
-PKG_VERSION:=2.4.2
+PKG_VERSION:=2.4.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ffmpeg.org/releases/
-PKG_MD5SUM:=9e6163b09b7b9331b834d80874c2c0ff
+PKG_MD5SUM:=7e2819c71484ffba1ba1a91dd5285643
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=LGPL-2.1+ GPL-2+ LGPL-3
diff --git a/multimedia/ffmpeg/patches/010-remove_unused_fminf_definition.patch b/multimedia/ffmpeg/patches/010-remove_unused_fminf_definition.patch
deleted file mode 100644
index 7dc0c27ac..000000000
--- a/multimedia/ffmpeg/patches/010-remove_unused_fminf_definition.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/libavutil/libm.h
-+++ b/libavutil/libm.h
-@@ -82,6 +82,7 @@ static av_always_inline float cbrtf(floa
- #define exp2f(x) ((float)exp2(x))
- #endif /* HAVE_EXP2F */
-
-+/* ---------- BROKEN: Defined in math.h but not present in uClibc 0.9.33.2
- #if !HAVE_FMINF
- #undef fminf
- static av_always_inline av_const float fminf(float x, float y)
-@@ -91,6 +92,7 @@ static av_always_inline av_const float f
- return x > y ? y : (x == x ? x : y);
- }
- #endif
-+------------------------------------------------------------------------- */
-
- #if !HAVE_ISINF
- static av_always_inline av_const int isinf(float x)