aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-02-17 07:49:01 +0100
committerNicolas Thill <nico@openwrt.org>2015-02-17 07:49:01 +0100
commit38ae2398c22d88895d5f7293d5536d21e184ba59 (patch)
tree57f786fb3d8187045123a67728547fd2bce64282 /multimedia
parentdd17d21b2f1fd51778d2664def498ebd6df01f13 (diff)
ices: import from old packages feed
- update to latest version (v2.0.2) - add license info - add myself as maintainer Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ices/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/multimedia/ices/Makefile b/multimedia/ices/Makefile
new file mode 100644
index 000000000..a3cb714ae
--- /dev/null
+++ b/multimedia/ices/Makefile
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2009-2015 OpenWrt.org
+# Copyright (C) 2009 Freifunk Leipzig
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ices
+PKG_VERSION:=2.0.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ices/
+PKG_MD5SUM:=832c448cc993170a70fd95804fcda5b2
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ices
+ SECTION:=sound
+ CATEGORY:=Sound
+ TITLE:=ices client for Icecast media streaming servers
+ URL:=http://www.icecast.org/ices/
+ DEPENDS:=+libshout +libxml2 +zlib +libogg +libvorbis +alsa-lib
+endef
+
+define Package/ices/description
+ ices is a command line source client for Icecast media streaming servers.
+ It began as the successor of the old "shout" utility, and has since gained a
+ lot of useful features.
+endef
+
+CONFIGURE_ARGS+= \
+ --with-ogg="$(STAGING_DIR)/usr/include" \
+ --with-vorbis="$(STAGING_DIR)/usr/include" \
+
+define Package/ices/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/ices $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,ices))