aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-03-19 22:28:15 -0700
committerRosen Penev <rosenp@gmail.com>2020-03-19 23:44:41 -0700
commit269ec782eb472b2deccfb3fddc8d297c24e990e0 (patch)
treed0fd22df34c318bfc1cf986b9ec9e59f88b8ea53 /multimedia
parentf58c2f97135dcc97c07879f1c6ca516c1b33fde4 (diff)
minidlna: fix build with newer musl
The configure script is totally broken and does not check for clock_gettime. Define it manually. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/minidlna/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/multimedia/minidlna/Makefile b/multimedia/minidlna/Makefile
index 80d24f816..fb69aa4f9 100644
--- a/multimedia/minidlna/Makefile
+++ b/multimedia/minidlna/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=minidlna
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://git.code.sf.net/p/minidlna/git
@@ -48,7 +48,7 @@ define Package/minidlna/conffiles
/etc/config/minidlna
endef
-CONFIGURE_ARGS +=\
+CONFIGURE_ARGS += \
--with-libiconv-prefix="$(ICONV_PREFIX)" \
--with-libintl-prefix="$(INTL_PREFIX)" \
--with-os-name="OpenWrt Linux" \
@@ -57,6 +57,8 @@ CONFIGURE_ARGS +=\
--with-db-path="/var/run/minidlna" \
--with-log-path="/var/log"
+TARGET_CFLAGS += -DHAVE_CLOCK_GETTIME
+
define Package/minidlna/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/minidlnad $(1)/usr/sbin/minidlnad