aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-25 00:58:40 -0700
committerRosen Penev <rosenp@gmail.com>2020-07-25 01:35:05 -0700
commit0001f9fcf60932ee22f1070212616e570029b52e (patch)
tree30825962d48f828dd2c8139452602a9119406bbb /multimedia
parent11c2d4d21ccc6a4a0e15233ae1a16664ba0eff2c (diff)
gstreamer1: update to 1.17.2
Added gettext-full host dependency. Normally it comes wth glib2, but in the update to 2.65, it goes away. Add it here. Refresh patch. Add one for systems lacking distutils. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer1/Makefile6
-rw-r--r--multimedia/gstreamer1/patches/010-gstplugin-use-lazy-symbol-binding.patch4
-rw-r--r--multimedia/gstreamer1/patches/020-distutils.patch11
3 files changed, 16 insertions, 5 deletions
diff --git a/multimedia/gstreamer1/Makefile b/multimedia/gstreamer1/Makefile
index a33c36091..4425c6915 100644
--- a/multimedia/gstreamer1/Makefile
+++ b/multimedia/gstreamer1/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gstreamer1
-PKG_VERSION:=1.17.1
+PKG_VERSION:=1.17.2
PKG_RELEASE:=1
PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gstreamer
-PKG_HASH:=f63566152755aab98414feb859ea8b00d3b07cad2486f304a8feec1265e5aa0e
+PKG_HASH:=0163bb2c086759411b686526e7d8f4b22efc4ac02ddf3941f66b14949f106eef
PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
@@ -23,7 +23,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:gstreamer_project:gstreamer
PKG_INSTALL:=1
-PKG_BUILD_DEPENDS:=meson/host glib2/host
+PKG_BUILD_DEPENDS:=meson/host glib2/host gettext-full/host
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
diff --git a/multimedia/gstreamer1/patches/010-gstplugin-use-lazy-symbol-binding.patch b/multimedia/gstreamer1/patches/010-gstplugin-use-lazy-symbol-binding.patch
index ab72a4ffa..11ea46556 100644
--- a/multimedia/gstreamer1/patches/010-gstplugin-use-lazy-symbol-binding.patch
+++ b/multimedia/gstreamer1/patches/010-gstplugin-use-lazy-symbol-binding.patch
@@ -1,8 +1,8 @@
--- a/gst/gstplugin.c
+++ b/gst/gstplugin.c
-@@ -777,15 +777,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
- goto return_error;
+@@ -790,15 +790,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
}
+ #endif
- flags = G_MODULE_BIND_LOCAL;
- /* libgstpython.so is the gst-python plugin loader. It needs to be loaded with
diff --git a/multimedia/gstreamer1/patches/020-distutils.patch b/multimedia/gstreamer1/patches/020-distutils.patch
new file mode 100644
index 000000000..d072c11bf
--- /dev/null
+++ b/multimedia/gstreamer1/patches/020-distutils.patch
@@ -0,0 +1,11 @@
+--- a/meson.build
++++ b/meson.build
+@@ -505,7 +505,7 @@ if get_option('default_library') == 'static'
+ endif
+
+ # Used in gst/parse/meson.build and below
+-python3 = import('python').find_installation()
++python3 = 'python3'
+
+ bashcomp_option = get_option('bash-completion')
+ bashcomp_dep = dependency('bash-completion', version : '>= 2.0', required : bashcomp_option)