aboutsummaryrefslogtreecommitdiff
path: root/multimedia/motion/patches
diff options
context:
space:
mode:
authorRoger <rogerdammit@gmail.com>2014-07-28 20:50:53 -0500
committerRoger <rogerdammit@gmail.com>2014-07-28 20:50:53 -0500
commitdf02327dc14dc6b55a0f29e431ab673af498d251 (patch)
tree43a1824d0f73ac8ce34db9a84d8fde64e9ade7ac /multimedia/motion/patches
parentec6d0154a729297490d01fec918b893f548c303c (diff)
motion: add from old packages
Signed-off-by: Roger D rogerdammit@gmail.com
Diffstat (limited to 'multimedia/motion/patches')
-rw-r--r--multimedia/motion/patches/002-honor_cppflags.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/multimedia/motion/patches/002-honor_cppflags.patch b/multimedia/motion/patches/002-honor_cppflags.patch
new file mode 100644
index 000000000..ac10f1e9c
--- /dev/null
+++ b/multimedia/motion/patches/002-honor_cppflags.patch
@@ -0,0 +1,19 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -31,6 +31,7 @@ examplesdir = $(datadir)/@PACKAGE_NAME@-
+ # install. #
+ ################################################################################
+ CFLAGS = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\" -Dsysconfdir=\"$(sysconfdir)\"
++CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ VIDEO_OBJ = @VIDEO@
+@@ -118,7 +119,7 @@ endif
+ ################################################################################
+ $(DEPEND_FILE): *.h $(SRC)
+ @echo "Generating dependencies, please wait..."
+- @$(CC) $(CFLAGS) -M $(SRC) > .tmp
++ @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
+ @mv -f .tmp $(DEPEND_FILE)
+ @echo
+