aboutsummaryrefslogtreecommitdiff
path: root/multimedia/imagemagick/Makefile
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-01-31 14:53:27 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-04 16:08:11 -0800
commitf14b3c66f6e697da446030be241e34f5ec573d4a (patch)
tree1e67c3c712c228ec78b535d5fde245b6ffdece3d /multimedia/imagemagick/Makefile
parent31337dd963c1ab3aa93e8f9269be37c1893b94ba (diff)
imagemagick: update to 7.1.1-27
- Use official source URL - Add libstdcpp dependency - Don't set configure options which are matching default values Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'multimedia/imagemagick/Makefile')
-rw-r--r--multimedia/imagemagick/Makefile35
1 files changed, 8 insertions, 27 deletions
diff --git a/multimedia/imagemagick/Makefile b/multimedia/imagemagick/Makefile
index 4f0a976ab..4d4f423c3 100644
--- a/multimedia/imagemagick/Makefile
+++ b/multimedia/imagemagick/Makefile
@@ -6,14 +6,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=imagemagick
-PKG_VERSION:=7.0.9
-PKG_REVISION:=5
-PKG_RELEASE:=4
+PKG_VERSION:=7.1.1
+PKG_REVISION:=27
+PKG_RELEASE:=1
PKG_MAINTAINER:=Val Kulkov <val.kulkov@gmail.com>
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REVISION).tar.gz
-PKG_SOURCE_URL:=http://github.com/ImageMagick/ImageMagick/archive/$(PKG_VERSION)-$(PKG_REVISION)
-PKG_HASH:=d15abd31e7e18f7edec47df156773a23e5100386e55c6ce50f5353e9572d3413
+PKG_SOURCE:=ImageMagick-$(PKG_VERSION)-$(PKG_REVISION).tar.gz
+PKG_SOURCE_URL:=https://imagemagick.org/archive
+PKG_HASH:=df0af0386df5bb3333ac9b1173ac4c893dcdd20b28100128e857f3d8f6466e1a
PKG_BUILD_DIR:=$(BUILD_DIR)/ImageMagick-$(PKG_VERSION)-$(PKG_REVISION)
PKG_FIXUP:=autoreconf
@@ -35,7 +35,7 @@ endef
define Package/imagemagick
$(call Package/imagemagick/Default)
- DEPENDS:=+libltdl +libpthread +zlib +libfreetype +libpng +libjpeg +libtiff
+ DEPENDS:=+libltdl +libpthread +zlib +libfreetype +libpng +libjpeg +libtiff +libstdcpp
endef
define Package/imagemagick/description
@@ -63,27 +63,16 @@ define Package/imagemagick/conffiles
endef
CONFIGURE_ARGS += \
- --enable-shared \
--disable-static \
--disable-docs \
--enable-dependency-tracking \
--with-modules \
- --with-threads \
- --with-ltdl \
- --with-zlib \
--disable-hdri \
--with-quantum-depth=8 \
- --disable-deprecated \
--disable-cipher \
--without-bzlib \
- --without-autotrace \
--without-djvu \
- --without-dps \
- --without-fftw \
- --without-flif \
- --without-fpx \
--without-fontconfig \
- --without-gslib \
--without-gvc \
--without-heic \
--without-jbig \
@@ -98,17 +87,9 @@ CONFIGURE_ARGS += \
--without-webp \
--without-x \
--without-zstd \
- --without-gslib \
- --without-gvc \
--without-pango \
- --without-perl \
- --without-rsvg \
--without-wmf \
- --without-xml \
- --with-freetype \
- --with-jpeg \
- --with-png \
- --with-tiff
+ --without-xml
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include