aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ices
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2021-02-09 22:27:53 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2021-02-09 22:27:55 +0100
commit550cf88885e4f114dc25f1f19e50736b25039531 (patch)
treebe3d3ba5e1bb260facdf1b9b33ea4b15263e6849 /multimedia/ices
parentb1b72378340e15f73bf3412e856ccd56e8ae75a2 (diff)
ices: allow access to iconv
Since commit d18692c libxml2 is linked against iconv. Now ices needs access to iconv as well. Without it the build fails. checking for ftime... yes checking for XML configuration checking for xml2-config... /builder/shared-workdir/build/sdk/staging_dir/target-aarch64_generic_musl/host/bin/xml2-config checking for xmlParseFile... no configure: error: Unable to link with libxml Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'multimedia/ices')
-rw-r--r--multimedia/ices/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/ices/Makefile b/multimedia/ices/Makefile
index 3120968f7..9fe41219d 100644
--- a/multimedia/ices/Makefile
+++ b/multimedia/ices/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ices
PKG_VERSION:=2.0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ices/
@@ -22,13 +22,14 @@ PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
define Package/ices
SECTION:=sound
CATEGORY:=Sound
TITLE:=ices client for Icecast media streaming servers
URL:=http://www.icecast.org/ices/
- DEPENDS:=+libshout +libxml2 +zlib +libogg +libvorbis +alsa-lib
+ DEPENDS:=+libshout +libxml2 +zlib +libogg +libvorbis +alsa-lib $(ICONV_DEPENDS)
endef
define Package/ices/description