aboutsummaryrefslogtreecommitdiff
path: root/multimedia/icecast
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2021-02-09 22:15:46 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2021-02-09 23:09:48 +0100
commit451d7872dfc3918be5798aa1470b914c366f211c (patch)
tree77d7bfb6862aa5303f8feb89a32338c1adc3f46c /multimedia/icecast
parent986c8acd555b1634de7dd1fab1aad5009f44347f (diff)
icecast: allow access to iconv
Since commit d18692c libxml2 (and by extension libxslt) is linked against iconv. Now icecast needs access to iconv as well. Without it the build fails. xslt.c: In function 'xsltSaveResultToString': xslt.c:72:5: warning: this 'if' clause does not guard... [-Wmisleading-indentation] if (result->children == NULL) ^~ xslt.c:75:2: note: ...this statement, but the latter is misleadingly indented as if it were guarded by the 'if' buf = xmlAllocOutputBuffer(NULL); ^~~ xslt.c:81:27: error: dereferencing pointer to incomplete type 'xmlBuf' {aka 'struct _xmlBuf'} *doc_txt_len = buf->conv->use; ^~ make[6]: *** [Makefile:545: xslt.o] Error 1 make[6]: Leaving directory '/openwrt/build_dir/target-mips_24kc_musl/icecast-2.4.4/src' Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'multimedia/icecast')
-rw-r--r--multimedia/icecast/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/icecast/Makefile b/multimedia/icecast/Makefile
index da7601eab..f3b4d96d7 100644
--- a/multimedia/icecast/Makefile
+++ b/multimedia/icecast/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=icecast
PKG_VERSION:=2.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.xiph.org/releases/icecast/
@@ -24,11 +24,12 @@ PKG_FIXUP:=autoreconf
PKG_INSTALL:= 1
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
define Package/icecast
SECTION:=multimedia
CATEGORY:=Multimedia
- DEPENDS:=+libcurl +libxml2 +libxslt +libogg +libvorbisidec
+ DEPENDS:=+libcurl +libxml2 +libxslt +libogg +libvorbisidec $(ICONV_DEPENDS)
TITLE:=A streaming media server for Ogg/Vorbis and MP3 audio streams
USERID:=icecast=87:icecast=87
URL:=https://icecast.org/