aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gst1-plugins-ugly/Makefile
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-09-16 16:17:24 -0400
committerTed Hess <thess@kitschensync.net>2014-09-17 13:00:56 -0400
commit8227368777cb2e0d9e1be0c295c8701c742f4e63 (patch)
tree85d25b76bf617d90af220a8c5c2994710b432661 /multimedia/gst1-plugins-ugly/Makefile
parentab9becdc10197d909ae9aa7fe486d4ed1c55ada1 (diff)
gstreamer1: reorganize options selection menus
gst-plugins-bad: plugins-bad package missing (fix install def) Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'multimedia/gst1-plugins-ugly/Makefile')
-rw-r--r--multimedia/gst1-plugins-ugly/Makefile52
1 files changed, 43 insertions, 9 deletions
diff --git a/multimedia/gst1-plugins-ugly/Makefile b/multimedia/gst1-plugins-ugly/Makefile
index 27929d026..da574e0b4 100644
--- a/multimedia/gst1-plugins-ugly/Makefile
+++ b/multimedia/gst1-plugins-ugly/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gst1-plugins-ugly
PKG_VERSION:=1.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
@@ -21,7 +21,7 @@ PKG_SOURCE:=gst-plugins-ugly-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
PKG_MD5SUM:=7ae60e2f759f58f32af5fcdc3c9193c4
-PKG_BUILD_DEPENDS:= gstreamer1 gst1-plugins-base liboil
+PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_gst1-mod-asf \
CONFIG_PACKAGE_gst1-mod-lame \
@@ -34,33 +34,63 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
-define Package/gstreamer1/Default
+GST_UGLY_MODULES:=
+
+define Package/gstreamer1-ugly/Default
CATEGORY:=Multimedia
SECTION:=multimedia
TITLE:=GStreamer
URL:=http://gstreamer.freedesktop.org/
- DEPENDS:= $(ICONV_DEPENDS)
+ DEPENDS:= +libgstreamer1 $(ICONV_DEPENDS)
endef
-define Package/gstreamer1/description/Default
+define Package/gstreamer1-ugly/description/Default
GStreamer open source multimedia framework
endef
define Package/gst1-plugins-ugly
-$(call Package/gstreamer1/Default)
+$(call Package/gstreamer1-ugly/Default)
TITLE+= plugins collection (ugly)
DEPENDS+= $(GST_DEPENDS)
+ HIDDEN:=1
endef
define Package/gts-plugins-ugly/description
-$(call Package/gstreamer1/description/Default)
+$(call Package/gstreamer1-ugly/description/Default)
.
This meta package contains only dependencies to the other plugins from
the ugly plugins collection.
endef
+define Package/gstreamer1-plugins-ugly
+ $(call Package/gstreamer1-ugly/Default)
+ TITLE+= plugins collection (ugly)
+ DEPENDS:=+ALL:gst1-plugins-ugly +gstreamer1-plugins-base
+endef
+
+define Package/gstreamer1-plugins-ugly/config
+ menu "Select GStreamer ugly modules"
+ depends on PACKAGE_gstreamer1-plugins-ugly
+
+
+ config gst1-plugins-ugly-all
+ bool "Include all GStreamer ugly plugins"
+ select PACKAGE_gst1-plugins-ugly
+
+ comment "Modules"
+
+ $(foreach mod,$(GST_UGLY_MODULES), \
+ config PACKAGE_gst1-mod-$(mod)
+ prompt "GStreamer $(mod) module"
+
+ )
+
+ endmenu
+
+endef
+
GST_COND_SELECT = $(patsubst %,$(if $(CONFIG_PACKAGE_gst1-mod-$(1)),--enable,--disable)-%,$(1))
GST_VERSION:=1.0
@@ -111,14 +141,17 @@ define GstBuildPlugin
GST_DEPENDS += +gst1-mod-$(1)
+ GST_UGLY_MODULES+= $(1)
+
define Package/gst1-mod-$(1)
- $(call Package/gstreamer1/Default)
+ $(call Package/gstreamer1-ugly/Default)
TITLE+= $(2) plugin (ugly)
DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
+ HIDDEN:=1
endef
define Package/gst1-mod-$(1)/description
- $(call Package/gstreamer1/description/Default)
+ $(call Package/gstreamer1-ugly/description/Default)
.
This package contains the GStreamer $(2) plugin.
endef
@@ -139,4 +172,5 @@ $(eval $(call GstBuildPlugin,lame,MP3 encoder (using LAME),audio,,+lame-lib))
$(eval $(call GstBuildPlugin,mad,MP3 decoder (using MAD),audio tag,,+libid3tag +libmad))
$(eval $(call GstBuildPlugin,mpeg2dec,MPEG decoder,video,,+libmpeg2))
+$(eval $(call BuildPackage,gstreamer1-plugins-ugly))
$(eval $(call BuildPackage,gst1-plugins-ugly))