aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gst1-plugins-base
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-25 01:04:33 -0700
committerRosen Penev <rosenp@gmail.com>2020-07-25 01:36:02 -0700
commitdad781503042b3ac8a9506e50c9ce9f0fd32f8b3 (patch)
tree0b6261fee04c0da2d01e06dc5fb9645b787d160b /multimedia/gst1-plugins-base
parent0001f9fcf60932ee22f1070212616e570029b52e (diff)
gst1-plugins-base: update to 1.17.2
Fixed some typos. Added patch to fix compilation without distutils. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'multimedia/gst1-plugins-base')
-rw-r--r--multimedia/gst1-plugins-base/Makefile8
-rw-r--r--multimedia/gst1-plugins-base/patches/010-distutils.patch11
2 files changed, 15 insertions, 4 deletions
diff --git a/multimedia/gst1-plugins-base/Makefile b/multimedia/gst1-plugins-base/Makefile
index 624ba9937..30cb4cb1d 100644
--- a/multimedia/gst1-plugins-base/Makefile
+++ b/multimedia/gst1-plugins-base/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gst1-plugins-base
-PKG_VERSION:=1.17.1
+PKG_VERSION:=1.17.2
PKG_RELEASE:=1
PKG_SOURCE:=gst-plugins-base-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gst-plugins-base
-PKG_HASH:=c0d8a84e3262e706ebc88831ca7349e5ae221274ef362599734573b3d3c028f3
+PKG_HASH:=30bfdaad8faa380fd74c3e74261748e218649786939ad10edfe067a39d4c4996
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-base-$(PKG_VERSION)
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
@@ -310,10 +310,10 @@ $(eval $(call GstBuildPlugin,volume,volume,audio controller,,+liboil))
$(eval $(call GstBuildPlugin,alsa,ALSA audio source/sink,audio tag,,+alsa-lib))
$(eval $(call GstBuildPlugin,ivorbisdec,Integer Vorbis decoder plugin for devices without floating point,audio tag,,+libvorbisidec))
#$(eval $(call GstBuildPlugin,cdparanoia,cdparanoia,,+libcdparanoia))
-#$(eval $(call GstBuildPlugin,libvisual,libvisual audio visualization,,+alsa-lib))
+#$(eval $(call GstBuildPlugin,libvisual,libvisual audio visualization,,+libvisual))
$(eval $(call GstBuildPlugin,ogg,ogg parser muxer demuxer,riff tag pbutils video,,+libogg))
$(eval $(call GstBuildPlugin,opus,OPUS audio codec,pbutils video,,+libopus))
-#$(eval $(call GstBuildPlugin,pango,Pango text rendering and overlay plugin,,+libopus))
+#$(eval $(call GstBuildPlugin,pango,Pango text rendering and overlay plugin,,+pango))
$(eval $(call GstBuildPlugin,theora,Theora,tag video,,+libogg +libtheora))
$(eval $(call GstBuildPlugin,vorbis,Vorbis,audio tag,ogg,+libvorbis))
diff --git a/multimedia/gst1-plugins-base/patches/010-distutils.patch b/multimedia/gst1-plugins-base/patches/010-distutils.patch
new file mode 100644
index 000000000..a7276e26e
--- /dev/null
+++ b/multimedia/gst1-plugins-base/patches/010-distutils.patch
@@ -0,0 +1,11 @@
+--- a/meson.build
++++ b/meson.build
+@@ -400,7 +400,7 @@ if get_option('default_library') == 'shared'
+ plugins_pkgconfig_install_dir = disabler()
+ endif
+
+-python3 = import('python').find_installation()
++python3 = 'python3'
+ subdir('gst-libs')
+ subdir('gst')
+ subdir('ext')